Firewall config for iPhone access

Hi All,

I have an iPhone that has worked on previous iterations of Comodo Firewall (v2) for internet access.
I’m running:
AMD 4200 / 2G ram / 2x WD 180G Hard Drives
XP Home SP3 w/all current updates
abit AirPace wi-fi card set up as access point
RCN broadband internet access

My problem is this:
Since upgrading to Comodo v3, I’ve had some issues. Most of the time, i get great access to internet from my iPhone via wi-fi access point, good speeds, very few problems. Until I use a bookmark whose site requires login information. I am either not able to access these sites, or get interminable wait times between screens, with frequent “cannot access server” messages (on the phone). I recently tried unchecking “block fragmented IP datagrams”, which seems to have helped, if not cured my problem. Questions:

  1. what are my risks in continuing with this feature deselected?
  2. are there other avenues I can try instead of this?
  3. is this likely just a feature of how iPhone, or AirPace card as access point, handles traffic?

Any suggestions would help.
I live in a residential building, where I’m unlikely to have much risk from prying nasties via the wifi, but i have WPA2 authentication nonetheless.



Just a quick thought off the top of my head - do the login screens a HTTPS page? If so, does your firewall allow access to port 443?

Ewen :slight_smile:

https screens not a problem that I know of. One of my problem sites is an online scheduler service where the login information is embedded in the URL, and the other is a forum such as this, neither with https. My bank’s online site is such a pain to access, with multiple challenge questions, that I don’t even bother with it on the 'phone.

If so, does your firewall allow access to port 443?
Unsure how to check this. I have the phone's MAC address included in my network zones, and identified as safe or with unlimited access everywhere I can find to do so.

Thanks for the reply, Ewen
I realize that this could be such a niche combination that I may never fully resolve it.
When I can get the funds, I’ll get a wireless router and forgo the access point card.


Does it work if you disable the firewall and Defense+ (right click system tray icon and select DISABLED for both “Firewall Security Level” and “Defense+ Security Level”?

That’s odd. After disabling both firewall and defense+, everything seemed to work fine. Then I re-enabled both and everything works still (even with fragmented IP datagrams checked), although sporadically. About half the time I get a “server stopped responding” dialog on the 'phone.

I apparently still have a problem somewhere in the mix, though it may be a hardware one. (Signal strength from the wi-fi card fluctuates, even from short distances; maybe it’s ■■■■)

I’ve just noticed that CIS is out and I’m psyched! I may go ahead and install that and see what problems that brings up ;), unless there’s something obvious that stands out in your thoughts.

Thanks for the help so far…

NP Erik. The sporadic problems could be caused by fluctuating signals from the AP or it could be a DHCP related issue (where the phone was able to get an IP when everything was disabled, but couldn’t when it had to renew then lease). Of course it wouldn’t be a fault in an Apple product. :wink:

CIS is a real gem!. It’s not perfect, but nothing is. The vast majority of users are exceptionally happy and it is proving to be remarkably stable and efficient on the vast majority of PCs its installed on.

Let us know how you get on.

Ewen :slight_smile: