Firewall causing port to be reading as stealth?


Recently I had a belkin router and everything was working fine but it died on Friday and I am using the backup Netgear WGR614v9, which seems to be working except for the fact that when i try to port forward for utorrent (which worked fine with the old router) it doesnt work, the port reads as closed or in stealth.

I have been told that this may be due to the comodo firewall that I have active, could that be the case? I tried to exit the firewall from the system tray and it appeared to close but someone on the netgear forum stated that I neede to uninstall the firewall?

Does comodo stay active even after exiting it from the system tray? I just want to eleiminate the firewall as the cause before looking at anything else (although I have eliminated most otherobvious possibilities).

Some extra info:
I am using Vista and running AVAST anti-virus

Thanks in advance.

If you’ve forwarded the ports correctly in your router, you’ll still need to open both inbound and outbound ports in the firewall.

Take a look at this, see if it helps Utorrent Setup

Hi ryoden,

It’s more likely to be caused by the router you have swapped because that’s the part that got replaced.
You haven’t changed anything to your PC, and as it was working before it’s not likely to be caused by CIS.
Unless you switched from uPNP to static ports etc.

You don’t have to exit the GUI, you can just right click on it and then select ‘Firewall Security Level’ remember it’s current setting and set it to disabled. If things start to work by then it’s caused by CIS, if it’s still not working it’s caused by the router config.

Ok thanks, that’s what I thought but as I am unfamilier with how the firewall operated i thought it best to check :wink:

I had a look at your guide, which seems more complex than my current setup (which was working fine with the previous belkin router) my utorrent has two rules - allow all IP in and allow all IP out. Is this bad for any reason as it seemed to work fine previously? After reading your guide it got me wondering if I had it set up wrong.

It’s not “bad” just unnecessary. Some like control over their connections, some don’t…

Hmm that is odd. I have got the belkin fixed and have reconnected it … and I have the same problem which makes no sense.

Just out of interest I have uninstalled the firewall to see if it makes any difference but the only change was that the shields up site now lists the port as closed rather than stealth.

Any ideas?

How did you fix the Belkin? Are you sure uPnP in enabled at the Belkin router.

The senior tech guy phoned me and made some changes to my ip address and the router and managed to access it again then reconnected to the internet (previously I couldnt even access the router webpage).

Yes UP&P is on. The odd thing I have noticed is that the shields up site reads the port as closed (or stealth if windows firewall is on) but the portforward program is reading it as open for TCP or UDP?

I was beginning to think that Virgin were blocking ports since i have tried to forward about 10different ones but they stated this morning that they do not block ports. I have no idea of what to try next.

I reread your topic start. When you close down CIS from the tray you only close the client program (GUI); the firewall and D+ will continue doing their jobs. If you want to disable the firewall click right on the icon in the systray and under Firewall Security Level disable it. Don’t forget to enable it again as you will not be reminded.

Now you can continue testing.

Cheers, I have solved the problem, it was a utorrent setting of all things. It shouldnt have been there but it was and when the router was reset to factory settings I used a differnt ip address this caused the conflict.

Thanks all.