Firewall causes system to go unresponsive when browser sandbox icons clicked

This is the latest version cis internet security and anti virus downloaded as of Jan. 19, 2015.

Windows 7 professional 64bit
Hp dc7900 model computer
3.0 gig cpu
3 gig ram
150 gig hd
MS security essentials installed

I first installed the cis with anti virus and dragon and It installed no problem, rebooted, but slowed my system down a little on reboot.

I installed chromium and ice dragon next.

They all were slow to open when the desktop icons were clicked.

When I clicked the sandbox browser icons from the desktop widget, it acted like it was opening but nothing happened. This happened on all three icons for dragon, chromium and ice dragon.

After clicking the sandbox browser icons.

The system became unstable and unresponsive and now all desktop exe icons failed to execute the associated program and hung. The keyboard now became unresponsive but the mouse still worked. All icons on the desktop were broken and the system was locked up. No control, alt, delete, nothing worked.

I had to do a hard shut down and reboot.

Tried again and same system failure but I was able to do a ctrl, alt, del to the task manager where I tried to close comodo down but it refused to close 1 thread process called virtual something . exe which kept jumping around the process window and had two threads open tht refused to close when ended.

I had to hard shut down again because the system was uncontrollable and unresponsive.

I used comodo program manger to un install the firewall anti virus and it was a little shaky doing that with pop up message it didn’t like something and a reboot was needed. It worked and my system was back to normal.

I thought about it and tried just the firewall install without the anti virus and it went just fine but that little quirk is still there when I try to click the sandbox browser icons on the desktop widget. It crashes all the desktop icons from opening after I click one of those widget icons to open a sandboxed browser

So what gives.

More forensic details.

I opened task manager after a reboot and saw no process threads other than cis.exe and comodo in the active applications window which is fine.

I clicked on icedragon in the sandbox icon from the desktop comodo widget; It acted like the exe was executed but nothing happened. The task manager reported that virtualkiosk.exe opened but shut right away and icedragon.exe opened but nothing happened as it remained active in the process report.

I tried to close the icedragon.exe process thread but it would not close and another icedragon.exe thread opened and I was able to close that one, but the first one remained open and refused to end.

This cause the system to become unstable and unresponsive and I clicked desktop icons and the system locked up. No keyboard, no shut down, nothing. So I had to do a hard shut down and reboot was slow but everything comes back to normal till I click one of those browser in a sandbox icons and virtuakkiosk.exe executes and than all hell breaks loose.

See if disabling Microsoft Security Essentials makes a difference.

I thought that may have interfere with the firewall and anti virus so uninstalled it but the virtualkiosk issue stayed with a fresh install of the firewall.

Stand by and I will disable the MS security essentials.

Msconfig / startup / unchecked security essentials and rebooted

Security essentials did not load, I than clicked the dragon sandboxed icon and still the same issue with system going “not responding” but I was able to open task manager by ctrl, alt, del and in the process section a virtual mode process was open but closed out leaving dragon * 32 process open and I could not end that process by highlighting it and clicking end.

The system became unresponsive and had to hard shut down and boot up.

Can you see what happens when you disable hardware acceleration in Dragon?

Nothing, still becomes unresponsive if sandbox icons clicked. The restart option worked but hung at shut down and had to do a hard shut down still. Sandbox activated browser in the processes is holding the system hostage

From what I can see so far, this has something to do with virtkiosk.exe.

I went into security essentials and excluded the processes for virtkiosk and dragon exe.

What I saw from the process viewer was that virtkiosk opened and shut with MsMpEng.exe then opening a large number of MsMpEng.exe disk reads. MsMpEng is part of defender/security essentials scanning. So, is virtkiosk doing something to rattle the security essential virus scanner into action, I don’t really know.

I have now found opening dragon and switching to the virtual mode option from the drop down browser menu causes the same issue as clicking one of the sandbox icons on the widget. The PC becomes unstable and fails to respond to mouse clicks and keyboard control is lost so a hard shut down is needed to reboot.

It’s odd that Defender is still working in the background even though it was disabled.

Can you try disabling Windows Defender Service in Services (Control Panel → Administrative Tools) and see what happens?

Services shows defender is set to manual and I selected stop and saved so its not starting up.

Security essentials in services is running and the options to stop it are grayed out so can’t do anything there. I did stop it from loading at start up. My guess is it is still running in the background and from what it does is stops software it doesn’t like.

The event viewer says when I click the option to exe virtkiosk the system stops the kernel and halts.

Looks like security essentials MsMpSvc relies upon MsMpEng to execute.

Virtkiosk triggers a stop code to the kernel and the system stops. Does virtkiosk have a driver that’s triggering this.

Disregard this image, It maybe when I have to hard shut down the system and not from comodo

I wrote a whole explanation to what I found and got it to work. Unfortunately some one lurking in the deep dark web stopped my information from posting and a login screen appeared after I hit post even though I was already logged in.

The problem is!

MS security essentials and virtkiosk.exe fighting for your computers control.

You were probably logged in for an hour. Use this page to log in and make sure to set it to always stay logged in.

The problem is!

MS security essentials and virtkiosk.exe fighting for your computers control.

Does this topic at the Microsoft forums bring a solution?

I went into security essentials and settings where I clicked on real time protection and unchecked it. Of course it shuts down security essentials from protecting the system and that allowed virtkiosk.exe to run virtual mode on the sandboxed browsers.

I notice the same issue on my vista machine with security essentials going nuts when virtual mode is initiated on the browsers.

So, why is security essentials treating virtkiosk.exe this way

Why that is is beyound my knowledge base. It may worth a bug report though.