Firewall blocks trusted app

I have installed Amazon’s Kindle for PC. It works well, and when first run it was defined as a trusted app. Still shows in that list.

But when I go to update (over the net), I get the popup that asks permission to access the web. By the time I can click on the OK box, the app has already decided it’s blocked.

It is trusted, and I have made sure the “remember my answer” box is checked on the ensuing attempts, yet still not allowed to go get more.

The only way I can get a new book is to close CIS, log off and back on, close CIS again, and then do the download.

HELP!! and many thanks for your shared wisdom.

ps - I’ve tried what I can find on the various boards, but to no avail.

Is the updater a separate program? Make sure it is made Outgoing Only or Trusted. Look it up in Firewall → Advanced → Network Security Policy → Application Rules.

Try excluding Kindle in the Image Execution Control Settings under D+. It worked for me when having a program as trusted didn’t work. Assuming you are 100% comfortable with the program as a safe one.

Ken