Firewall blocks my virtual hosts

Can someone explain me where is the problem and what I should configure? I am very novice in firewalls at all…

I am developer so I have Apache webserver on my local comp and everything is just ok when I am connected to Internet. I am using cell phone gprs at home if this is important. But… When I am disconnected all virtual domains become unavailable for me…

Say localhost is working… But (virtual domain name) is not available in browser… The same is for mail server… I am running local mail server on other virtual domain and mail is not available as well… All these domains are listed in hosts file of course… So I think maybe the problem is in this?.. If I will try to disable firewall everything work well…

Thank you in advance!!!

so… nobody knows… :frowning: Any ideas please?..

please… someone… help me…

I know nearly nothing but I’d suggest you try going to Security > Tasks > Add/Remove/Modify Zone, add your LAN, and then right over there in Tasks define it as Trusted Network. Maybe this is nonsense but since nobody else answers…

If you go to “Security>Network Monitor” and Turn Off the Network Monitor does this allow you to connect?

Does the log (Activity>Logs) show anything being blocked.


In Security/Advanced/Miscellaneous, there are two boxes, “Skip loopback…TCP (and UDP)” One is set by default, the other is not. Checking both boxes might help.




The problem is that and localhost is available. but ‘devel’ - not… If I turn off monitor, ‘devel’ is up as well…

I tried all recommendations… Nothing helped… :slight_smile:

Not sure what sort of connectivity you need to access the ‘devel’ side of things, or what you need/want to allow. Obviously you need Inbound. I presume you have certain protocols on certain ports for this, both In and Out from the server, defined in/by the server itself.

What if you go to Network Monitor and open that.

Right-click the top rule (rule ID 0) and select Add/Add Before.

Create a rule like this;

Action: Allow
Protocol: TCP/UDP (correct protocol?)
Direction: In
Source IP: Any
Destination IP: Hostname:
Source Port: Any
Destination Port: the port(s) assigned for Inbound on these protocols

Now right-click Rule ID 0 again, select Add/Add Before

Action: Allow
Protocol: TCP/UDP
Direction: Out
Source IP: Hostname:
Source Port: the port(s) assigned for Outbound on these protocols
Destination Port: Any


If that works, then do the same thing for any other of these virtual domains you’re running on the Apache server. The key thing is you will want those rules at the “top” of the Network Monitor, so that they are prioritized before anything else that might interfere or conflict.