FireWall blocks my ports

Hi,i got a problem with CIS 3.8.65951.477 32bit version and lower.I allowed in Network Security Policy my application,which i using for IGMP video stream.I defined two rules,“Allow all incoming and outgoing request” and “Allow TCP OR UDP In/Out from IP Any to IP Any where source port is Any and destination port is Any”,but firewall still not allow IGMP communication.I got same problem with Apex DC++,I created same two rules,but I still can’t connect to another users.

If I change option in “Stealth ports wizard” to Define a new… or Alert me incoming…,then IGMP and DC++ works fine,but i need my ports Blocked,so I choose a 3rd option,Block all incoming… .I thought,that this 2 rules above will solve my problem,but my ports are closed for that applications,even I created “Allow TCP OR UDP In/Out from IP Any to IP Any where source port is Any and destination port is Any” rule.Why?

Sorry for my bad English,i hope u will understand my problem :slight_smile:

Nobody? :cry:

Welcome to the forum Whistler :slight_smile:
Inbound rules should be in Global rules.
Try two rules one inbound one outbound.

Hello,thank you for welcoming me :).

It ofcourse works,when I add a Global rule “Allow IP In from IP Any to IP Any where protocol is Any”.But it makes my computer not stealth.I just need to allow all communication for only 2 specific applications,not as a Global rule :frowning:

What I need is:

In Global rules: “Block and log IP In from IP Any to IP Any where protocol is Any”(this is how to Stealth ports wizard configures rules)

In Application rules: “Allow IP In from IP Any to IP Any where protocol is Any”. I need to allow communication for specific applications,i don’t want to make a global rule,just per-application rule.But this isn’t work :frowning:

Here is what I need

Hello Whistler,

If you would like to say host a webserver, that would take you to create 1 manual rule and 1 manual or “alert” rule.

If you would open let’s say Incoming From Any Source port Any to Destination Any Destination Port 80 and you apply that, the first user trying to access your webserver would cause an “Alert” that will be matched against your Application rules for let’s say Apache webserver.

Hello Ronny,i don’t use my computer as a web server.

I got problem with just 2 applications.The first,in red cyrcle on image im my post above,is application,which I uses for IGMP video streaming (it’s my provider’s IPTV application).

My second problem is with Apex DC++,I can connect to server,everyone can download from me,but I can’t connect to any user.If I disable firewall,problem dissapears.

I know, i was just using that as an example on how this should work.

If you say IGMP you are talking about multicast traffic, Can you try that and see what your firewall log shows it dropped, my guess would be “protocol 88” rules are dropped somewhere down the line…

Try this
Edit the application rules and Change to trusted application

I ofcourse try that,doesn’t work.

I don’t think so,that changing settings can solve my problem.I think it’s firewall problem (bug).

To allow incoming traffic you have to open the “port(s)” your application needs, and your application also needs the rules to accept it, there is no other way in this firewall.

For IGMP traffic you can create a global rule, Allow (and log) IP from ANY to ANY protocol IGMP.
If you would like to tighten that up, take a look at what’s logging for 224.0.0.x addresses and make rules accordingly. This will also alert you for probably Windows Operating System incoming alerts also apply them there.

Ronny,thx for your advice,I understand everythink you said,but it just doesn’t work.I course try a create a global rule “Allow (and log) IP from ANY to ANY protocol IGMP”,doesn’t work.I course allow IGMP communications to system (It asks),doesn’t work.I can see in firewall events,that my firewall blocks IGMP communication for Window Operating System,I really don’t know why,I try everything,I made “system” as a trusted application,but no effect.

I also got problem with Apex DC++,ruled as trusted application,i can connect to hub,users can download from me,but I can’t connect to any user.

I know,that problem is in Global rule “Block and log IP In from IP Any to IP Any where protocol is Any”,if I remove this rule,everythink is gonna be fine.

In my opinion,if I create a global rule “Block and log IP In from IP Any to IP Any where protocol is Any”,it means,that I want block all incoming communication.But,if in Application rules I create a rule for application,it means,that I globally want block communication,but not for that one application,which I Allowed to communication.

So,I think,this doesn’t work and imho it’s a firewall BUG.

Everything else is OK,Opera,IE,Miranda is OK,just Apex DC++ and my videostreaming application have problem.

I am really sorry for my english,i hope you will understand :slight_smile:

and stealth ports wizard…
Changing to “Alert me to incoming connections…” to see what happens
Have you tried?


Make sure your created rules are above the “Block rules”, if you still see blocked IGMP traffic to “Windows operating system” try the following.

Open Firewall policy, Applications tab, click Add, Select “Running process” and select “Windows Operating System”. Create an allow IP Any Any IGMP rule on it.

Save the policy and, just to be sure reboot…

Or wait, try this before the above, go to Firewall, Advanced, Attack Detection and disable “Block fragmented packets” and see if that helps ? Is there anything else enabled there ?

Tried both,no effect.I also try reset all settings fo CIS to default and configure again,doesn’t work,still blocking.

Ok,forget it for now,I will just Disable firewall,when I will use that 2 applications :slight_smile:

Thank u for your time guys :slight_smile: