Firewall blocks HP DeskJet 3520 scanner


I can’t configure firewall to stop blocking my wireless HP DeskJet scanner. Adding and adjusting existing application rule didn’t work.

Option “Block fragmented IP traffic” is unchecked.

Many thanks in advance for any tips how to solve it.

From the log it appears you do have block fragmented IP traffic enabled, clear the logs and check again. Also what version of CIS is installed? There was an old version that had a bug where it would still block fragmented IP traffic even if the settings was off.

My version is and I checked the settings again but I can clearly see that block fragmented IP traffic is disabled (unchecked box).

Following your advise about logs i cleared them. However CF is not logging new events no matter how many times I restart scanner application or restart laptop.

On the side note CF is installed on Windows 10 Home

Have you tried deleting the existing rule, running the scanner application again and then (once it’s shown as a network intrusion in the GUI) unblocking it through Comodo’s “Unblock Applications” task?

First things first, I’m assuming that you have installed the DeskJet scanning app and are sending a scan from the printer to your PC.

If this is correct, then your printer/scanner is initiating an inbound connection to your PC and the firewall is stopping it because that’s it’s job.

To test this, you could create a global firewall rule with the following parameters;


Click ADD
Action : ALLOW
Protocol : UDP
Direction : IN
Source Address : TYPE → IP V4 SINGLE ADDRESS →
Destination Address : TYPE → IP V4 SINGLE ADDRESS →
Source Port : ANY
Destination Port : ANY
Click OK

In the list of Global Rules, your new rule should now appear. Make sure it is above any BLOCK rule or any EXCLUDE based rule that could prevent it running.

The above rule will allow inbound UDP traffic from your scanner/printer IP address through the CIS firewall to your PCs IP address.

You will still need to ensure “Block frgamented packets” is still DISABLED. Similarly if you have a NAS or a Media Server, blocking fragmented packets will also stop their data streams from reaching your PC.

Hope this helps,
Ewen :slight_smile:

I am sorry for not replying earlier. I didn’t expect to get any answer so quick and I simply forgot about my topic.
Anyway, if my memory serves me well I tried to remove existing rule and even modify but without luck.
I attempted to create global rule without any success as well. So I decided to forget the scanner and kept using CF as normal.

Last post by panic would suggest solution however I am no longer able to reproduce error I experienced earlier. I removed today old version of CF, installed latest one ( and voila! No problems at all.

Seems like previous version of CF was broken somehow.

Anyway thank you for your help, guys.