Firewall blocks everything while using p2p programs


I have a big problem with the comodo firewall.

When I’m using P2P programs, for example utorrent, I can’t open most programs, can’t access any internet sites with any browser I have. Firefox just tries to load the page forever. If I’m not connected to the internet, Firefox shows the “connection failed” page (or whatever).
Further, any internet connection another program tries to establish will also be blocked.

When I try to check for updates within my utorrent, it also tells me that it can’t contact the update server.

It seems that everything except the established TCP and UDP connection(s) is blocked by the comodo firewall.

As I stop downloading anything (and close the P2P program) and wait for maybe 20 seconds, all programs I tried to open, magically appear and I can access the internet as usual.

What is going on here? And most important, how can I solve this problem without ever using P2P programs again?

The same problem occurs with the latest update of the Kaspersky Firewall (no problems before that) while I have no problems at all with the (quite unsecure) Kerio Personal Firewall.

I’m using WinXP SP2, a cable connection and I am “alway connected”.

Please help me, I don’t want to go back to my old Kerio Personal Firewall again.

Edit: I made some testing.

The problem occurs with utorrent (and maybe other bittorrent programs) and not with programs such as emule.

When I open utorrent, everything else is still funktioning properly.

As soon as I start a download, every other program can’t access the internet (web browser, emal ect.). The download in utporrent as not affected in any way!

Only when I stop the download AND close utorrent and wait some 30 seconds, I can access the internet with my other programs as usual.

Hi Reddy,

I just want to tell you that you are not alone with this problem. I have it too and I’m using a bittorrent client called BitSpirit. All internetaccess is blocked: Internet Explorer, Firefox, all programs live update services, even e-mail is blocked!

I hope they will fix this as I really like this Firewall and I don’t want to go back to F-Secure


Are you using the encryption feature? If yes disable the option “secure against trojan protocols” on CPF

The “Secure against trojan protocols” IS disabled.

I found out that if you check the option “Skip advanced security check” for the program in the Application Monitor everything works again!



yes, after setting utorrent.exe to “Skip advanced security check” everything works just fine.

Thank you very much.

No I can enjoy my new safe firewall. You made me happy!

This doesn’t work for me. I’ve set uTorrent.exe to “Allow all activities for this application”, “Skip advanced security check”, “Allow invisible connection attempts”. “Secure against trojan protocols” is unchecked. I even restarted to make sure. Can anyone help, or I’ll have to change firewalls yet again…

We are going to release a second BETa next week. I think it wil solve all your problems.