Firewall blocks access to my own LAN... Temporarily...?


I am a Comodo newbie.

A moment ago I had the (free) Comodo Firewall set to “Custom.” Then, when I tried to browse my own LAN, I could not: I could see no other machine. Each share displayed its computer as “Unknown.” If I tried to browse, I got the error that I did not have access.

Next, I modified my Comodo setting to “Allow All.” In an instant, I could browse my LAN.

But then things got more interesting:

I changed the Comodo setting back to “Custom”, and could continue to browse the LAN with no problem.

What might cause this odd behavior? And what can I do to prevent the blocking in the first place?

Sincere thanks,


Can you please export your firewall logs and post them here so we can see what was going on.

Thanks in advance,
Ewen :slight_smile:

Hi Ewen,

I read the helpfile with some care in an attempt to learn how to dump the log, but had no success when searching for “log” or “logs.”

Next, I searched for “export” and the helpfile hung up.

I tried to close it, but could not because it was “locked by the system.”

Next, I tried to close Comodo, but it was also locked.

After a re-boot, I am now writing to you.

Can you assist?

Sincere thanks,


Hi again,

Well, the logging is not going to help…

Here were the steps I just took:

1: set Comodo to Custom

2: cleared the logs in Comodo.

3: attempted to browse LAN (all shares were “unknown.”

4: set Comodo to “Allow All”

5: refreshed LAN view (all shares visible)

6: set Comodo to Custom

7: refreshed LAN view (all shares still visible)

8: viewed Comodo log contents. Still blank.

Might you have any other suggestions to decipher this?

Thanks, as before,


My bad.

Should have said to ensure that ALL network monitor rules are set to create an alert (log entry) if the rule is triggered.

Sorry for that.

Ewen :slight_smile:

Hi again,

I appreciate your suggestion, but have no idea how to set it up.

Might you describe?



Hey Ken,

Now that my dose of dumbass pills has worn off, and I’ve re-read your original posting, all you probably need to do to be able to access your LAN while running CPF is to define a zone that covers the IP addresses of your LAN (including any routers) and to set that zone as trusted.

To do this, open CPF and click on the SECURITY button at the top of the CPF window and then click on the TASKS button on the left hand side. This will show the tasks window. Click on “Add/Remove/Modify a Zone”. In the “Modify Zone” window, click the ADD button. You should give your Zone a meaningful name (“Home LAN”, “Work LAN” etc.) and then type in the address range that covers your LAN. This will usually be from to, but this is not guaranteed. Once you have completed these details click OK and the newly defined zone will now appear in the list of defined zones. Click OK again to return to the TASKS window.

Now, click on “Define a trusted network”. In the small window that opens up, select the zone we have just defined and complete the wizard. This will automatically create the network monitor rules you need to be able to access your LAN.

For your info, this is how to enable logging for network monitor rules;

If you open CPF and click on the SECURITY button at the top of the window and then click on the NETWORK MONITOR button on the left, this will show the current network monitor rules. Double click on the first rule (rule 0) and in the Network Control Rule window that opens, you should have an option at the top of the window “Create an alert if this rule is fired”.

Selecting this option means that every time this rule is used to allow or to block traffic (depending upon the selected action for that rule), CPF will create a log entry.

Repeat these steps for all current network monitor rules.

Hope all this helps, and sorry for the initial confusion.

Ewen :slight_smile:

Hi again Ewen,

I sincerely appreciate your detailed suggestion, and I will certainly give it a try, but a question remains:

When my LAN is unavailable, I set the firewall to “Allow All.” As we might expect, that fixes things.

But then, when I reset the firewall to “Custom” I can continue to browse my LAN, even though that is the very setting that had blocked access to the LAN moments before.

Can you explain to me how that might be possible? It happens every time I re-boot, and I just don’t get it.

Sincere thanks once again,


Hey Ken,


That’s odd, really odd.

Can you follow the steps I outlined earlier for turning on logging for all rules, and then do whatever it is you do to get it to fail and then export the logs and post them here.

Also, let us know what type of network are you connecting to (ethernet cable or wireless) and what, if any, other security software you are running.

Ewen :slight_smile: