Firewall blocking some applications even after allowing them in CFW 10[solved]

Hello, first time posting here, but long time COMODO user (for longer than 5 years).

Ever since I updated to Comodo 10, the firewall seems to have an habit of picking on some specific applications and blocking them even if I add them to exceptions. It doesn’t happen with all of them, but some specific ones, apparently. In the previous version, every time an application was blocked, I could easily add it to exceptions and Comodo would allow it to connect, but seems like that’s not the case anymore with some, making allowing applications a daunting (and frustrating) task.

I’ve seen a lot of posts of this kind, but they all seem to be related to old versions of Comodo. Many of them point out to Defense+ (Never had a problem with that myself, although I don’t see it anymore, is it the new HIPS?). I’ve tried adding it to exceptions to HIPS as well, but no dice. What makes me think it’s the firewall is that as soon as I disable the firewall, the application can connect just fine without problems. I can even by connecting to it using my external IP address (It’s a server type application). As soon as I enable it, connection is lost.

Any ideas? :-\

[Edit] Forgot to mention. I use Windows 7 x64 Professional Edition, the server application, both x64 and x86 versions won’t accept connections as long as the firewall is up, however (not sure if it has to do anything with it) if I connect to my localhost or through my internal router IP, it accepts the connection. External connections will just not happen. I don’t see the Log showing inbound or outbound connections either.

[Edit 2] Decided to just look on every nook and cranny of the security suite and found the Stealth Ports options. Setting it to “warn of incoming connections” seems to have fixed the issue… wish I had found it sooner :smiley: