Firewall Blocking Programs

I installed COMODO Firewall. Everything works great, however there are a few things that I am having issues with. Logitech SetPoint (Mouse control panel), Avira AntiVir (Manual Update/ Auto Update), PunkBuster (Anticheat program that runs in the background of videogames, in my case Americas Army 3.0).

I am using windows XP. Now I add these files when it says they are waiting for review into “My Own Safe Files”. Also, logitech is being blocked from accessing memory. It says it’s trying to get into one of comodo’s files but like I said it’s just the software for my mouse.

Avira is allowed to autoupdate, however it keep blocking files under the FAILSAFE folder. It could be a backup trying to be created. I can’t manually update anymore the update screen just sits there and waits. I added everything from Avira I could.

Punkbuster is also being listed under wait for review. I add them, play AA3, and they are back in the list.

I have added all of these files to “My Own Safe Files”, “Computer Security Policy”, and “Network Security Policy”. But still these things keep being blocked. I shouldn’t have to manually add these things in. I should just run them and add them when the firewall asks. Also, all of these are programs used by millions of people. So COMODO should already have them allowed under the forewall.

What should I do?

Apparently those files change a lot and as a consequence they get place in the My Pending Files. Best way to get rid of this is to set Defense + to Safe Mode instead of Clean PC Mode. This can be done under Defense + → Advanced → Defene + settings.

Try this and let us know how things are after the change.

  • Punkbuster seems to not be showing up at all.
  • Setpoint.exe (logitech) is still being blocked from accessing memory
  • Avira AntiVir is only updating using auto updates and one the virus definitions update. The detection won’t update.

For setpoint.exe. This is a memory sharing issue, simple to resolve.

Select Defense+ -->Advanced → Computer Security Policy.
Scroll down to Comodo Internet Security, select Edit → Protection Settings.
Interprocess memory Access (Active Yes) select Modify → Add -->Now use Running Processes or Browse to point to the concerned file(s) .
Then just “Apply” to each window as you exit.

I don’t quite understand what you are trying to say about Avira. Can you rephrase it?

Okay so here is what is weird about it.

  • I try running the update and the screen is stuck on “searching for updates”
  • I let the manual update run and it does 1 of 2 things. Before it was just updating 1 of the 2 files for some reason. Now however, it seems to be updating both te files correctly (Don’t know what was going on there and maybe the problem will return). Still though, I would like the option to manually update.

Right now Avira is updated. But like I said if I try to manually update the screen just sits there looking for updates.

If your running Avira Free the update servers do sometimes take a while to respond. Some things you can check/do are to have a look in Firewall/Advanced/Network security policy/Application rules->There should be 2 entries that are needed for Avira, these are Avira…update.exe and Avira…AvNotify.exe, you can highlight these entries and set them to the pre-defined policy “Outgoing Only”

Also have a look in Defence+/Advanced/Computer Security Policy->here you will find several entries related to Avira(you can group them together by holding the left mouse button down, a red line appears, then move to desired location) you wan`t Avira…update.exe, double click it and tick the box “Use a pre-defined policy” and then from the drop-down choose “Installer or Updater”, APPLY to close all windows.

Matt