Firewall blocking Linkstation (network attached storage)


I have Comodo Internet Security 5.0 (this issue was the same with v4) and a Buffalo Linkstation.

Whenever I restart the PC, the Linkstation shows in Windows Explorer as “Disconnected Network Drive” and I cannot reconnected it by clicking through to it. No programs are able to access it.

In order to access it, I have to briefly disable CIS Firewall, then click through to the Linkstation.

Once I have done that, I can then re-enable the firewall and from that point on, I can access the Linkstation without problems.

Obviously I would prefer not to have to disable the firewall at all. Have you come across this problem, and do you have any suggestions? Thanks,


The problem is with how Comodo works. It will not trust any device that can be removed, socalled mounted devices. Think: USB flash drives, networked drives, USB drives, encrypted drives…

The reasoning is that these devices are not constantly monitored and therefor might get infected.

Hi Eric,

Thanks for this.

I don’t have any problem with USB drives, etc: they are automatically detected and accessible. It is just the Linkstation.

I seems odd that the only way of connecting it is by disabling the entire firewall, which I am extremely uncomfortable doing. And once the drive is connected, I can re-enable the firewall, and CIS works fine, including with the Linkstation.

Is there no better way of connecting an external drive than turning off the firewall? Thanks,


Then may be I made a wrong analysis.

New angle. Your NAS device needs to be part of a trusted local network zone.

How to make your local network a trusted zone.

First look up your IP address and subnet mask. In Windows go to Start → Run → cmd → enter → ipconfig → enter → now lookup your IP address and subnet mask.

Second create a zone in My Network Zones (Firewall → Network Security policy). Choose Add → A New Network Zone → fill in a name like My local network → Apply. Now select My Local Network Zone → Add → A new address → choose An IP Address Mask → fill in your local IP something like 192.168.1.x usually and your subnet mask; usually → Apply. Now check and see the new network defined. Exit using Apply.

Now we are going to use the Stealth Ports Wizard to make your local network a trusted network:
Choose “Define a new trusted network and stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → choose your local network zone from the drop down box at the bottom → Finish.

Now check your Global Rules and see your network added.

Hi Eric,

Perfect - thanks.

That also sorted out the problem where I couldn’t get my folder sharing to work: i.e. I hadn’t been able to access shared folders on another PC which was attached to the same router. It now works fine.

Thanks again,