Firewall blocking internet

First of… What the hell is going on? ???

You guys made the best firewall i’ve known, but why didn’t you anticipate something like this could happen? I have to switch to allow all just to connect to the internet, and then switch to custom rules fast every time I start my computer!

This is, sorry to say, unacceptable! what’t the point of having an awesome firewall if you can’t use it?

It would help a lot if you can explain a little more about the scenario.

How are you connected to the internet?

When/How did this start (when you installed, or have you been using it for a while, etc)?

When you are not able to connect to the internet, have you checked the logs for relevant entries? If Comodo is blocking something, it will be logged…

When you installed the FW, did you use the default “Automatic” install mode, or did you choose the manual “Advanced” where you are required to do all configuring by hand?

Do you have, in the Application Monitor, a Block rule for svchost.exe?

If you’re not able to connect, there is a reason… Comodo doesn’t just block the internet and force you to choose “Allow All” in order to connect. If you can connect that way, and stay connected after switching back to “Custom” that makes me suspect that you’ve blocked svchost.exe (but we’ll have to see).

At any rate, we can get you through this, and out on the other side (where there are happy, green pastures filled with firewall goodness, and everyone looks like this: :BNC ).


PS: Welcome to the forums, by the way!

PPS: I’ve moved the topic to FW Help board, and changed the Subject to better reflect the issue

The firewall work just fine here, and it work just fine for many users! :slight_smile:

A friend also had some problems like you have, but with the logs from the firewall, we could trace down the problem, and fix it! (svchost.exe was blocked for example)

Hi I am also having the same problem. I installed Comodo yesterday. The first time I rebooted my PC, I could not connect to the Internet (using Verizon DSL). I got the prompt to ask if I want to allow svchost.exe, I clicked yes, but still I wasn’t able to connect. Checking the network icon, the problem is that no IP address was assigned.

I had to temporarily disable the firewall in order to connect. After I connected, I re-enabled the firewall, and it’s currently working.

I just chose svchost.exe as an “allowed application” in the Comodo GUI. Hopefully this solves the problem.

anyway there’s for the software. :slight_smile: