Firewall Block NFS Connection

If I enable ComodoFirewall to custom mode (Only Network Monitor ON)
NFS UDP Connection will broke.

Did not see anything in the activity logs.Neither UDP Flood nor IP Fragement are logged.

I’ve add the NIC and address using NFS to trusted network.

Hi ksc91u.

Are you referring to (NFS) Network File System or something else?

Toggie

Yes,Toggie
Network File System.

Server: Windows 2003 R2
Client Windows MCE with Service for Unix 3.5

Only way to make them connect is to disable firewall.

Server 2003 is 64Bit, correct?

CFP is not yet 64Bit compatible. Version 3, which is due out for public beta testing soon, will be 64Bit & Vista ready.

At the present, only XP Home/Pro, and Win2K are workable. Sorry to be the bearer of sad news.

But take hope; help is on the way with version 3…

LM

Server 2003 is 64Bit, correct?

It comes in both flavours LM.

ksc91u.

I assume you have just the two PS’s (server 2003 and MCE) on a LAN, and that you have some gateway to the Internet?

As you probably know NFS uses RPCs running over UDP on server port 2049 for stateless communication between clients and file servers on the network. For you to be able to connect to your server you will have to do a number of things.

  1. Create a new Zone that defines your LAN.
  2. Define a Trusted Network.
  3. Create rules, where necessary, to allow the flow of traffic between your two PC’s.

If you need some help doing this please don’t hesitate to ask.

Toggie

I think there might be problem with my NFS configuration or something else.
After a reboot, I can connect my NFS share again.

I…think maybe it is Windows 2003 problem, since I am also running Routing and Remote Access on the same machine.
Sometimes pc on private lan can ping the outside,but got no UDP or others, even when I disable CPF… after restart 2003 the NAT comes back again.

The new problem is UDP flooding attack.
I’ve search the forum and see there is no solution other than setting a greater UDP packets/s value?

Hope there will be per interface configuration in the next version.
I love the “advanced security configuration”.
But sometimes it is confusing that packets are first filtered by “advanced security configuration” and then by “Network Control Rules”.

Hope I am understandable.
Thanks for all your work. :BNC

Hi

it’s not possible for me to configure Comodo Firewall to allow NFS-Connections. I use the MS SFU-Tools and Comodo blocks any NFS-Connection, altough nfsclient.exe has been allowed to do anything it wants and the destination IP is activated for any protocol, port, etc. The logs tell me, that Comodo blocks “fake or fragmented” packets to this IP. Is this a bug?

regards