Firewall and Iomega Networked Hard Drive


I have an Iomega Networked External Harddrive that fits via an ethernet directly into my Router. A discovery manager software then maps the drives for use when the firewall is off.
When the firewall is on - no connection and the discovery manager cannot see the drive.
On further investigation i allowed the mac address of the hardrive full access via the firewall. The discovery manager can see the harddrive - the name of it appears - but still cannot connect unless disabled.

Are there any settings i may have missed to allow access?

-i had AVG firewall installed previously but it would never connect. Now i disabled it and am using Comodo firewall.

thank you!

I’m looking for the same solutions as well. My Iomega Home media network hard drive just could not find the drive through the Storage Manager, unless to uninstall COMODO firewall Pro.


Can you show us screenshots of the Global Rules (Firewall → Advanced → Network Security Policy) and the logs (Firewall → Common Tasks → View Firewall Events)?

Hi, there. I have just solved this issue. I have 3 PCs with XP and a Vista notebook, I tried to change the firewall and Defense+ on the main PC after I did some research online, but with no luck. I finally saw the Iomega access window last night after I changed somef settings. then I tried another 2 PCs, now I got little experience. Here is my tips:

  2. In Attack Detction Settings window, under Miscellaneous tab, click Block Fragmented IP datagrams and Do protocol analysis. (I think the 2nd one made it working).

the 2 screen shots you asked, I can show you, but I made lots of useless change there. I have gotten approved on the 3rd PC without COMODO at beginning then installed COMODO, and just do the 2 steps above, it works beautifully.


Congratulations with finding the solution your self.(:CLP)

Excellent.well found. I’ve just had a chance to catch up with the forum.
I found a solution without the manager. I set the mac code of the device to accepted netwrk and manually mapped the drives.