Firewall and Google

I have just installed Comodo pro and, find that the only way I can access GOOGLE sites either search or mail, is by disabling the firewall. All other sites including the Cromo, Firefox and IE browsers are OK. my default is Firefox.

can any body help.

I am using a Belkin MIMO G router


Try setting the firewall to training mode, and see if that helps, it should “learn” that your trying to access google and discontinue stopping your browser.

Make sure you’re not blocking Google’s IP (, you can check this under the firewall settings under advanced options, then go into the network security policy and check under global rules.