Firewall allows all applications to access th internet (Custom Policy) [Wifi]

Good day.

I had a great experience with Comodo CIS on my stationary PC. Great product.
Recently, i got an old notebook (HP 6715b) with Windows XP SP3 installed.
LAN controlled is dead, so I am using WLAN only.

After CIS installation I connected the laptop to the wireless. Cis asked something about network type, I selected the home network.

As always, I am using Custom policy mode… but Firewall doesn’t ask for anything, every application gets the access to the internet. In my Application Rules there is nothing about programs, that are currently on the internet (Firefox, uTorrent, etc.)

What should I do to get a classical Custom Policy mode ?
Is this unusual behavior caused by Wireless or because of this new feature with network type selection.
How to “reset” all applications and force firewall to ask about every application trying to access the internet ?

[attachment deleted by admin]

Partly Solved:

For some reason, in Firewall behavior settings “Create rules for safe applications” checkbox was unchecked.
After I enabled that option Firewall started to ask about application rights to connect to the internet.

But the reason why all applications became “Trusted” is still unclear.

To start with the latter. Apparently the Comodo white list is big enough to cover the programs you are using.

It is odd it is needed to have to enable “Create rules for safe applications”. I just tried on my Win 7 sp1 x86 and there switching to Custom Policy Mode was enough.

I remember I saw a similar case earlier today. May be it is an XP related issue.


Ok, may be it is good old XP. In any case, firewall works as it should now.

P.S. It was a mistake to buy used HP 6715b, it is too slow for anything but Firefox and uTorrent :slight_smile: