Firewall Alerts - Gone, Doesn't get triggered or off screen


My Comodo firewall doesn’t show any alert windows, neither firewall nor defence+.

I have, uninstalled comodo and reinstalled it. I’ve even uninstalled a second time, rebooted and removed every “comodo” keys in registry, and then reinstalled again.

I’ve tried the “comodo - proactive security” preset, tried with custom policy (as always been using) and even cleared the application white list (network security policy → application rules) and even after than ports and what not.

I finally added a top rule for executables to “ask” on IP - in/out - from any ip&port - to any ip&port.
Still it doesn’t get fired up, I need to manually add to the trusted application list. Otherwise no internet access.
I have set firewall to custom policy with alert frequency set to very high and enabled alerts on tcp, udp, icmp and loopback requests, but still doesn’t show any alert windows and blocks new applications that are not on the white list (application rules).

I can come up with 2 possibilities.

  1. The alert window is outside of screen space (off screen) and because it’s a child window of comodo, regular windows commands for moving application-windows doesn’t work (winkey + arrows).

  2. Comodo is faulty and alert window never gets called.

If it’s number one, where the heck can I find the settings for where the window should pop up? If its off screen that is. Is it in a file somewhere or in the registry? Note that uninstalling doesn’t remove old alert windows positions.

Please advice, thanks in advance.

You probably just need to disable the option “Do not show popup alerts” in the firewall behavior settings. Same for D+ also.

Thanks for the reply. Sorry that is not the case for me, this checkbox “Do not show popups alerts” is not checked. Any other ideas?

Additionally I noticed that “Active connections” window is always showing empty. No matter what applications do access the net they do not show up there.

I would love to know what registry keys and files that doesn’t get removed with uninstall. Clean refresh is what I want to try out. Anyone knows?

This indicates that the Firewall driver is not filtering your traffic else it would be able to ‘see’ it and display it.
I’d advise an uninstall + clean install.

You could also verify if the Firewall driver is attached to your Network Adapter by going to ‘Network and Sharing center’
Change Adapter settings, select your active adapter and verify if ‘Comodo Internet Security Firewall driver’ is attached as a service to this NIC.

Thanks for the reply, I have checked that the “COMODO Internet Security Firewall Driver” is indeed loaded for the NIC. And about the reinstall, I’ve already mentioned on my first post that a clean install has been made twice (with reboots) but without success.

Did you have had a version installed that it worked on? like 5.9 worked and now 5.10 no longer? or is this the first try with CIS?

Also can you please post your Adapter details, make, type etc it could be that CIS doesn’t recognize your hardware.

It should recognize the NIC, been using comodo firewall for 3 years on this computer.

I had an older version last week, don’t know which one but max 1 years old. It got broken then and it was after that it got broken I tried to update to latest, with clean install. No manual updates or so before it broke.
Maybe auto update might have done something previously I don’t know, I don’t even know when this happened exactly, just that firewall became so silent and new apps didn’t trigger the alert options. I notice these symptoms last week and have been trying to fix this since then.

So this is just an out of the blue experience for me.
Is comodo firewall depending on something, like .NET libraries or services that runs in background? Does comodo firewall depend on windows firewall?

Can you set the firewall to ‘Stop all traffic’ on the GUI’s summary screen, see if that blocks?

Parrallel to Ronny’s inquiry could you look into the following?

At Ronny. Feel free to instruct solidreactor to discard the following until further notice of your inquiry.

What other security programs do you have installed? Which one(s) are running in the background? Do you have program installed that interfere with networking. Wireshark, Netlimiter,etc…

Also make sure that there are no left overs of previously uninstalled security programs around. Not all uninstallers do a proper job. And left over applications, drivers or services can cause all sort of “interesting effects”.

Try using removal tools for those programs to remove them. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Does this help? When it doesn’t are you willing to try a clean installation? Uninstall CIS and reboot into Windows Safe Mode use this clean up tool to remove possible leftovers.

When done boot back in Windows and start Device Manager with the attached batch script.

When in Device Manager go to View in the menu bar and choose Show hidden devices. Under Non Plug and Play drivers you may see up to four Comodo drivers (see red square in the image).

Select them one by one, right click and choose uninstall from the context menu. If asked, do not reboot until all of them are uninstalled (it will save you time).

[attachment deleted by admin]