Firewall acts strange

Even if i list some trusted applications, Comodo Internet security’s firewall will block all incoming connections…It drives me crazy…I can’t use multiplayer games properly, I can’t use torrents properly…Please do something about it…I am really confused ??? ??? ???

Also, i use windows 7

I guess you have to do something. :wink:

torrents works fine here and MP games I dunno because I don’t play but they should work too.
Can you post your firewall log and application rule(s)?

Well No logs on firewall of blocking anything…Also, i can use torrents, but as i said…firewall won’t let incoming conection…also, disabling it from GUI(user interface) won’t do a thing…i have to go to network connections and disable Network firewall component, and then every torrent will go fine with High upload and many incoming connection…I use COMODO for over an year , and i like it…but The firewall can be better…

Which version are you using?

Also, try going to Firewall / Stealth Ports Wizard. From there select the middle option. See if that helps.

If it doesn’t I’d go to Firewall / Advanced / Netword Security Policy. Then delete the rule for the program that’s not working correctly.

If that also doesn’t work go to Defense+ / Common Tasks / My Own Safe Files. From here you should add the executable for the program in question to your safe files.

Hopefully one of these methods helps.

I am using the latest Version

Try what Chiron suggested you. If does not work try this: in Computer Security Policy, change “Treat as” for each executable form the games to “Installer / Updater”. Do you still have the problem?