Firewall 8.2.4508: UI and windows fail to open

hello, i come here with this report, it started happening since last update 8.2.4508

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
yes, very reliably

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
just try to open ANY Comodo related window, cis.exe pops in the task manager and immediately closes

One or two sentences explaining what actually happened:
nothing, clicked the tray icon, the desktop shortcut, start menu shortcut, tried any of the setting entries in the tray icon context menu (which along the widget is the only thing that is shown)

One or two sentences explaining what you expected to happen:
any of the UI windows to open

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
i tried to uninstall and reinstall, but the problem became worse, since all the rules were reset and no windows poped to ask for me to allow or deny for any request, my system became very unstable, so i had to uninstall again

Exact CIS version & configuration:, clean install

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
clean install configuration

Have you made any other changes to the default config? (egs here.):

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Ultimate, none, 64-bit, default, Administrator, no

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

Hi Drakkar,

Please follow the following procedure :

  1. Download attached archive.
    Note: Right-click main or main_x64 executable (from archive) > Properties > Compatibility > Tick “Run this program as an administrator”.
  2. Run the main executable (from archive).
  3. Wait… Some (procdump) windows should appear in order to monitor related processes.
    Note1: Do not close these windows.
    Note2: Please allow ALL procdump instances by choosing not to be asked of process/instance run if you’re experiencing such messages.
  4. Start ‘cistray.exe’ (or/and related troublesome actions).

A/Multiple full dump(s) should be automatically created in the working folder (of main executable). If so, please attach it/these.

Thank you.

[attachment deleted by admin]

thanks for your fast reply

i downloaded the attached file, extracted it, and ran the main_x64.exe file, agreed to the eula and all but the windows close themselves, with a Access Denied error, trying to open cis.exe or cistray.exe opens a procdump window but closes with Access Denied as well
of course, i already tried opening it with administrator privileges, and still nothing, tried the main.exe (the non 64 bit one) with admin privileges for the same result

i can’t restart comodo, since the Exit entry in the context menu does nothing and i can’t kill the process with the task manager

Have you tried taking ownership of the CIS folders?

clicking the Edit button i the ownership tab pops
“You only have permission to view the current owner for COMODO”

as far as i know, Comodo files are selfprotected to prevent viruses for tampering with them, isn’t it? that’s why i can’t change the ownership or kill the process isn’t it?

Please disable UAC temporarily and try again.

i can’t even open the UAC panel with Comodo running

reboot into Safe Mode

If possible, could you try to kill every process related to Comodo?

alright, i rebooted into safe mode, disabled UAC and took ownership of the folder, while there i ran the procdump file, and i managed to get some .dmp files

i get back into normal mode and try again, still Access Denied, i can’t terminate Comodo processes, an Access Denied pops

the .dmp files are around 115 MB is that normal?

Yes. Although I’m not sure if these are valid (probably not) considering that they were taken in ‘Safe Mode’. Please attach these as well.


Try to create another user account (with administrator rights, if possible) and use that one. Does the issue persist?
Also, make sure that you’ve used the removal tool properly.


it seems i can’t attach the .dmp files, i guess they are too big, the window to create a new user froze too
im going to try the removal tool

already did all i could, used ESET removal tool, nothing came up, Comodo tool, manually removing stray drivers and the problem persists, i uninstalled it since it blocks most of my actions since no window asking to allow or block comes up and cannot be turned off because the exit button does nothing, im terribly sorry to say it but im leaving it uninstalled for now, hope the problem gets solved in future releases

[at]Drakkar, please try to force a BSOD and attach a link to the complete memory dump.

Thank you.

I had similar problems after upgrading from v8.1 to 8.2 yesterday. My problem made it impossible to finish loading into Windows after logging in. I went to Safe Mode and I tried a System Restore but that didn’t fix the problem. Then I went back to Safe Mode to run the two separate uninstallers for Windows 7 64-bit (there is a post about the uninstall in this forum). Then I was able to boot into windows. I installed Comodo again (using the v8.2 installer) but then it wasn’t working correctly saying something about the comodo agent couldn’t start. So then I uninstalled Comodo through Add Remove programs (I had two of them there so I uninstalled both (I think one said Comodo and another said Comodo Firewall)) and ran the two separate uninstallers again and then installed v8.2 again (using the v8.2 installer) and everything seems to work fine afterwards except I lost my old settings. I rebooted whenever the uninstaller or installer said that I needed to reboot.

Windows 7 SP1 Pro 64-bit
I also use Asus AI Suite II which I thought may have conflicted with the 8.2 update since I saw errors about some Asus program having some error during the time I had the problem. I’m still using Asus AI Suite II after I got v8.2 working, though, and don’t see any more errors.

As there has been no response, I will move this one to “Resolved” section.