Firewall 5.10.x blocks Borland tool


To teach some coding fun to my niece, I need to use Borland C++ 5.5.1 compiler on Windows. I can compile the code but the Firewall blocks running program executable by throwing an error:

Access is denied.

I tried to fix at “Trusted Files” in Defense+, not helpful. I understand that Defense+ is blocking (a feature) programs by treating C++ EXEs as unrecognized files.

Q: what to do so that Defense+ to allow running executables in Blocked mode?

Thank you.

Give the Borland compiler the Installer/Updater policy in HIPS rules or Defense + rules when using v5.1x.

Hello EricJH,

It wasn’t an Installer issue, isn’t it? I’m getting that error while executing a program which uses the Borland C++ software. Please see the attachments:

bcc32 - Borland C++ files
cmd - error message
defense+ - added files under Computer Security Policy as “Trusted Application” mode

I added entire Borland Bin folder to “Exclusions” in “Execution Control Settings” of Defense+
I added entire Borland folder to “Trusted Files” of Defense+

Still no use - same error message.

Am I missing anything here? Appreciate the inputs, thank you.

[attachment deleted by admin]

With the Installer/Updater policy CIS will trust all sibling process of the main process. When working with compilers new files, which are unknown, will be created and or run.

Does that help?

Not yet unless I move each EXE file from “Unrecognized Files” tab to Trusted files…

BTW, I appreciate my solid Comodo for not giving up so easily! :-TU

Under Blocked mode (Defense+), every Unrecognized EXE getting blocked. I can disable it, but how to go through it without disabling?