Firerwall Custom Policy Mode broke in the Version 5.12

A. THE BUG/ISSUE: Firerwall Custom Policy Mode broke in the Version 5.12

  1. What you did: Updated CIS from Version 5.10 to 5.12
  2. What actually happened or you actually saw: Firewall in Custom Policy Mode broke. Custom Policy Mode does not alert to any applications at all and those applications that access the net are immediately trusted. It is like the Firewall is off.
  3. What you expected to happen or see:
  4. How you tried to fix it & what happened: Reinstall Comodo Internet Security. I fixed it with staying on Version 5.10 but this should not be the point.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
  8. Any other information (eg your guess regarding the cause, with reasons):
    This Guy had the same Problem:
    So i am not alone and i do not wanna know how much people running now a broken firewall.
    B. FILES APPENDED. (Please zip unless screenshots).:
  9. Screenshots of the Defense plus Active Processes List (Required for all issues):
  10. Screenshots illustrating the bug:
  11. Screenshots of related CIS event logs:
  12. A CIS config report or file:
  13. Crash or freeze dump file:
  14. Screenshot of More~About page. Can be used instead of typed product and AV database version:


  1. CIS version, AV database version & configuration:
  2. a) Have you updated (without uninstall) from a previous version of CIS: yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: yes
  3. a) Have you imported a config from a previous version of CIS: yes
    b) if so, have U tried a standard config (without losing settings - if not please do)?: yes
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels: Firewall Custom Policy Mode
  6. OS version, service pack, number of bits, UAC setting, & account type: Win 7 64 bit, SP 1
  7. Other security and utility software currently installed: none
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:

I’m just posting this to provide confirmation of the existence of this problem in the latest version. I’ve upgraded a few days ago and I’ve been going nuts reinstalling and reconfiguring Comodo Firewall because of it.

I’m glad I’ve read this too, because I already had my mind set to give up on Comodo after years using it and go for a different firewall product, least this be a new “feature” instead of a bug. Reverting to 5.10 until this is fixed.

Still, I’ll be VERY cautious about upgrading this product in the future. This is not just some minor glitch but a major, wide-level flaw affecting everyone’s security and privacy as soon as they install this latest version, it shouldn’t have been released to the public in this state and it raises questions about QA testing.

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post.

  • A.3, 5, 6, 7
  • B.1
  • C.1, 4, 8, 9

Please also check you have included all the information requested against each question you have already answered for example we would appreciate your UAC setting under c.6

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


PM reminder sent

its not just the custom policy, the firewall is not recognising programs alltogether, either trusted, friendly, blocked or any other rule, although this detection is quite random.

im also getting false reports of ipv6 outbound connections from ipv4 only programs (when the program is recognised)

i used the windows 8 version of cis 5.12 due to some issues with the win7 version not loading during system start up.

this is a serious flaw and makes comodo useless to me until it is fully resolved.

im attempting to roll back now in the hope the previous versions of the firewall will work, i would rather have to load it myself at boot than have no firewall.