Firefox updated itself for 32.0.3 and then HIPS started to block it! [merged]

I use firfox exclusively. I have had no problems for months now, but suddenly today I discovered that firefox had been sandboxed and I don’t know why?

Everything was fine yesterday.
Now when i click on the icon for firefox, it takes so long to load, and it actually never actually loads, instead I get a pop up annoncing that it
it is now in " the active process list" …what ever this means. I also get an pop up that announces to me that forfox is already running and will have to be closed first. where could it be running that I can’t discover?.. because I see nothing from Firefox on my screen. instead the loading symbol just spins and spns , I waited for it and waited, and it never appeared. I had ot resort to IE
SO why has it been sandboxed?
I have the latest updates,
I ran a virus scan on 9-02

I had a similar issue. My Firefox just updated itself to 32.0.3 version and when i tried to open it up again, comodo HIPS started to block it and asking me what i would like to do with a pop up window alert. The alerts keep it until i decided to uninstall Firefox 32.0.3, restarted my pc and installed it up again. I don’t know what happened, but the alerts stopped. Some bugs from Mozilla maybe? HIPS log is via the attachment.

[attachment deleted by admin]

Hello, there!
My Mozilla Firefox automatically updated to version 32.0.3 and then my Comodo Firewall HIPS started to block it preventing it to modify system keys.
The alert pop ups keep it up until i decided to uninstall Firefox, restarted my PC and reinstalled Firefox 32.0.3 from a new setup. The alerts stopped.
What happened? Firefox never did anything bad. I use this browser since 2007 and this never happened. Why this happened?
I’m sending the logs via the attachment. (It’s on portuguese, but i think you guys will understand.)

Thank You for any answers!

[attachment deleted by admin]

I merged your two topics.

There is probably a problem with the used certificate. Either they are using a new one that is not on the TVL yet or it’s not signed or the certificate has expired, or there was a problem with the revocation server…

I just updated FF to 32.0.3 from within FF but with CIS v8 beta the problem does not happen. I am on Win 8.1 x64.

Oh, ok, no problem, moderator.
Yeah, i thought it was a certificated problem indeed.

Does the problem still persist for the two of you or has it solved its self?

Well I’m not sure if my issue is resolved, I’m leaning towards that it is not. I m not certain what happened here, but I think some one else has / had a similar problem, and joined in on my post. I am unable to determine if I have / had the same issues as this other person. can you tell me?
As of today I have been dealing for days with an issue of Malwarebytes wants to update it’s data base and continues to inform me of that but when I click on allow , the allow appears to not work…I hope that makes sense. for example, for as long as I am in front of my computer malwarebytes continues to send me pop up requests to update the data base, and I click yes do now, and this continues and continues, so far it has been an hr. I never had this problem a week ago.

I assumed it could be an issue with sandbox. so I looked and what i found I made a screen print of so you can see what I see.
Funny this should happen for I thought Comodo CIS was designed to work flawlessly with Malwarebytes?..it has in the past 2 yrs. for me been that way.
in the attached screen prints you will see: c;/ program files Mazilla firefox\fr…

and you will see : c:\program files MalwarebytesA…

i am thinking these should not be here, for they are safe programs…are they not? and could them being here cause my updating issues and the fire fox issues I am having?
Do you see others that should not be there because they are safe? please, please point them out b/c I don’t have the skills to determine that.
I’m still using XP ; V 2002 pro with service pack 3

[attachment deleted by admin]

Is the problem with FF still happening? The screenshots are of September 28 where your post is of September 29. Does rebooting your system make the system go away?

MBAM gets blocked when accessing a folder in documents and settings. Do you have that folder added to your protected folders?