Firefox suddenly blocked after restart.

So i’ve just installed the new CFP after it installed i restarted my computer after that firefox was working fine. Had to do windows updates and had to restart again after that CFP is blocking firefox to connect to my homepage I also tried to set my home page to and still CFP was blocking it. The only way firefox will go to my homepage is if i disable the firewall then it works fine. I’ve checked all the rules and everything and made sure somehow firefox wasnt blocked. I even re added firefox to the trusted application list.

Any help or suggestions are appreciated.

Make Firefox a web browser in firewall rules. Also make it a trusted app in D+.

Thanks Vettetech However i had firefox my browser added correctly to the rules lsit and everything. But a complete reinstall of CFP did fix the problem. So thank you.

Ok… updated the firewall to today and… Again i have this same problem… But this time reinstalling CFP does not work. I’ve added my browser (FireFox) to Defense+ trusted apps Added it to the firewall rules. but still nothing.

Your doing something wrong . I just did a complete uninstall of .295 and installed .304 with no problems at all. Firefox works like a charm. Firefox is also whitelisted so you should not get a firewall pop up. I got a D+ pop up about Firefox-----flashgot. I clicked “trusted” and all is well. I have XP and my Comodo setting are all stock. Firefox is set as a web browser and custom in D+. Try deleting all Firefox entries and rebooting. Then let Comodo relearn them.

Took your advice and did what you told me. Restarted the computer opened Firefox little CFP popup says “firewall learning mozilla firefox” but still blocked by the firewall…

Ok… after everything i try to disable my anti virus (Avast 4.7 Home Edition) and now the firewall allows firefox to connect to the internet. Turned my Anti Virus back on and the firewall blocks firefox again…

Avast has a web shield which could be interfering. Make sure Avast is trusted in firewall settings. I think if you look at your log you will find your problem. Avast runs 4 processes I believe. All of them need to be trusted.

I have Avast set as a trusted application and the 4 processes are set in the firewall correctly. and when i check under the firewall event log all i find is “firefox blocked… source IP… Destination”

Alllllllllllllrighty. Well when i turn off just the Avast web shield… it all works fine. But i set avast web shield as a trusted application in CFP. So i still don’t understand what’s going on. Also Vettetech Thank you verrrrrry much for all your help and advice.

I don’t believe this has anything to due with messing up firefox and avast and also CFP ( Or could it?) but in XP “security Center” It says McAfee personal firewall is on. Odd thing is McAfee firewall and antivirus was installed on this computer when it came new. since then i’ve obviously uninstalled them also deleted all McAfee registry related entries and checked all the startup .exe’s to make sure McAfee firewall wasnt installed and… it’s not installed anywhere. So i have no idea what is going on now with this McAfee issue.

Had to do windows updates
I had this happen several times with 2.4 that I run on one of my drives. It was always after a windows update that Fx was blocked. The only way I could solve this in 2.4 was to delete FX from the app monitor and then reinstall it, and set the component monitor to learn for a while. FX 'net access was no problem until I did a M$ XP update, and then like clockwork it couldn't connect to the net.

did the issue ever get fully fixed?

Easily fixable. Type " services.msc" in the run box. Find the WMI service and stop it. Then go to C/Windows/Wbem/ and delete the repository folder. That will clear McAffee from the security center.

so the only WMI i found is " WMI Performance Adapter"

Its called Windows Management Instrumentation.