Firefox sandoxed problem

I’ve just upgraded from V8 to the latest one and I’ve got a problem when sandboxing Firefox 58.0. When I first sandbox it, it works perfectly fine. If I then exit it and then start it sandboxed again new tabs appear from my plugins like Ghostery and Adblock plus acting like they have just been installed for the first time. Things only work correctly again when I reset the sandbox. I never had this problem with V8 and I’m stuck at how to fix it.

Hi Dumper1,
May you please share snapshots on 1st start and 2nd start?

We will try to reproduce as well.


Win 10 1709 (16299.192) works fine here. This the 4th start and answering from the Sandbox

What’s OS you have and are you also using FF v58.0?

Win 10 1709 (16299.192) and FF 58 from 2 days ago when it upgraded

Yes, latest version released on 23rd Jan.
Lets see if any other user also has any problem with latest FF v58.

The first start is fine

I just tried it with Ghostery (which I don’t use), but no problem

What Configuration? Was there the initial Firewall warning? Did you accept or not?

No, I haven’t received any alerts. All settings are the same that I had for V8 before. Could the screenshot below be causing the problem?

Edit, I’m using Proactive security mode, Hips is Safe mode, and Firewall is custom ruleset.

I can replicate this now after 6 starts / closes running FF 58 as Virtual. It brings up Adblock Plus and Privacy Badger as ‘newly installed’ extensions

Thanks, we will check.

Has there been any progress with this problem?

We have not been able to re-produce as such, still being investigated.

Okay, thanks for the reply.

After the last FF update to 58.0.1 - still present with Privacy Badger, AdBlock Plus and Ghostery extensions

Also just the same in Virtual Desktop - open and close FF 2 or 3 times and same result

The issue was reproduced on our environment and we posted it as a bug. Solution is being investigated.

Kind Regards,

Good, thank you for the update.

Sadly this issue still persists in the latest version.