firefox process won´t quit after update of comodo

Hi guys,

I´m using vista 64, firefox 3.5 and the comodo free firewall. A few days ago it did an update (version is now 3.10.102194.530). Since then he firefoxprocess doesn´t end after I close the window. Therefore it counts up ff-processes until the cpu is used 100 % or I kill them manually.

First thought it to be a ff prob, but found an entry there from another user, having the same prob after updating comodo and solving it by removing the firewall.

Anyone got a solution without switching ?

Hi Jenna23, welcome to the forums.

I believe this issue is caused by a CIS add-on called SafeSurf, installed by previous version of CIS. Please uninstall SafeSurf & confirm if this resolved the problem. Thanks.

Wow, that was fast. Simply disabling Safesurf did the trick already.

tyvm

Yeah, that does the trick. But what if i want to be safesurfing? is that possible?
CIS 3.10 said to have a new toolbar instaed of safesurf yoolbar. does that mean that safesurf itself is obsolete?

What was SafeSurf has been replaced by both CIS (the Buffer Overflow component) & HopSurf, Comodo’s new replacement for SafeSurf. Melih has a recent topic on HopSurf & it’s installation here.

I hope that helps.

Ok, i’m clear on the toolbar part, but SafeSurf is not that ask comodo toolbar we has before the hopsurf one
SarfSurf and the SafeSurf Toolbar are two different things. So SafeSurf is replace by CIS and the SafeSurf Toolbar is replaced by A hopsurf one?

Btw: sorry if i hijacked this thread.

Yes, I believe that is the current state. Comodo Memory Firewall (CMF) was added into SafeSurf (with the Ask toolbar). Then CMF was added to CIS directly. The Ask toolbar was dropped and HopSurf stepped forward to fill the gap & add a new dimension of security, better explained by Melih (the CEO) in the topic I cited.

No problem. :slight_smile:

Just wanted to add my experience to this topic.

OS: Windows XP Home 32 bit, fully updated.
Problem: High CPU usage after closing Firefox and MS Internet Explorer

I was also having the same problem described by the OP. Closing Firefox would be followed by high, continuous CPU usage.
Was having problems with Firefox ver. 3.0.11 and they continued after upgrading to ver. 3.5. I would have to “End Process” firefox.exe from within Task Manager.
Also verified that I was having the same issue when closing MS Internet Explorer ver. 8.0.6001.18702. I would have to “End Process” both iexplore.exe items from within Task Manager to kill the high CPU usage.
Used System Restore back to a previous state (previous version of CIS and other apps) and the problem went away. Problem returned right after trying to upgrade CIS back to 3.10.

Choosing “Disable protection on all applications” from within SafeSurf ver. 1.0.0.7 by right clicking the icon in the system tray corrected the issue. Based on the previous discussion, I will un-install SafeSurf as it is no longer required.

I think it would be wise to program in the process of un-installing SafeSurf as part of the update process. And if a re-install is being performed, check to see if SafeSurf is installed and prompt to un-install.

Thank you for your support. I now have the solution that I need.

Hi GearGuy, welcome to the forums.

Thanks for your feedback. I cannot disagree with you that it would have been a fairly good idea the think though, and test, the CIS 3.10 upgrade with SafeSurf in mind. Unfortunately, being an add-on and not part of CIS directly, that didn’t seem to happen. Anyway, I’m glad your issue is resolved. :-TU

I saw an interesting workaround to use the integrated memory firewall of CIS solely in cooperation with the firewall. The idea was to install CIS with Defense + and then disable D+ only for the buffer overflow protection.

Thanks Kail. Glad to see that the un-install issue has been addressed with the latest update. You guys are doing a great job…

Cheers…