Firefox doesn't work right with Comodo Firewall

So the cmdagent.exe file goes all the way up to 100% in the task manager any time I open a new page in Firefox. I’m wondering what is going on? There had got to be a fix for this or if there isn’t one already, there needs to be a patch or something. Tons of people use Firefox. I’m hoping someone has an answer for me here, although I searched the forum and no answer was found yet. And it looked like there were several other people with the exact same problem, so I know it’s not a problem just with my system. Can someone help me out with this PLEASE?!! It’s taking like 45 seconds to load a page when normally it’s instant. It’s like having dial-up all over again! Someone please give me the answer. Thanks!

I had the same problem. This page was taking more than 2 minutes to load in Firefox with a broadband connection and CMDAGENT.EXE was using 30 to 40% of the CPU. :cry:

I did a search in this forum and found,6053.0.html. I tried his suggestion of going into Comodo firewall’s Application Behaviour Analysis and unchecking the Monitor DLL Injections section. 88)

This solved my problem. The page now loads in 7 to 8 seconds and there is no more high CPU usage with CMDAGENT.EXE. ;D

DLL injections are a very important thing to monitor, as it’s becoming one of the most used exploits. I’d try seeing if you have the latest version - this was a known issue in older versions.,6160.0.html

I have the latest version. The DLL injections monitoring is definitely the problem with the high CPU usage and web page slow down in my case. :o

Please try to find another solution. DLL injections are highly important. Even if you don’t, please do not recommend other users to turn it off, at least.

I am open for suggestions. Any ideas? The DLL injections monitoring was the only thing I tried (of many different configurations) that solved the problem, other than turning off the firewall.

I viewed the various links suggested and none of them worked.

Therefore, I tried uninstalling CFP and reinstalling, updating, etc. 88)

All appears to be running well now. ;D

Something must have been messed up after the first couple of auto updates, since this problem appeared after the auto updates. ???

The DLL injections monitoring is working now and not causing any problems after the reinstall of CFP. However, there must still be an issue with this due to the other posts in the forum and my problem which required a reinstall and relearning of all rules. >:(

When I uninstalled CFP, this was not an option so I am starting from scratch with all learning, etc.

If there is a way to save this info, how is it done? ???

BTW - I am still using the rest of KIS, but eventually hope the CAV will be good enough to replace the high cost KIS or KAV. :wink:

Oh, you mean this. It’s a sticky at the top of the Help board. I’ve never used it because I don’t mind starting from scratch on the settings and rules. I’m sure the next version 3 will have the ability to save configs from within the firewall.