Firefox CMDAgent 100% CPU usage bug stilll exists (v3.5.57173.432 x32)

I am still having problems with CMDAgent.exe going to 100%
This was reported as fixed in the Update to Version 3.5.55810.432 : 18th Nov, 2008
I updated from an original install of Version 3.5.54375.427 : 29th Oct, 2008. I did not reinstall.
I am running a very strict rule set “optimum security” imported from earlier versions.
It will allow IExplorer.exe v7.0.6000.16735 without a problem

I can fix it without a reboot, if I am patient and willing to wait and change to another configuration and then change back to “optimum security”. however this can take 5-10 minutes as my CPU is pegged at between 90% & 100%. the CPU usage dropes as soon as the new configuration is accepted. However the next time I launch Firefox it will go back to 100%.

if I reload Firefox, it will run fine for a while and then something will happen. I think it starts when I close Firefox and relaunch it before the Firefox process is completely terminated but I have not as yet verified this.

I am running
CFP 3.5.55810…432 Firewall & D+ only (no AV)
Firefox ver 3.0.4 (Updated)
No-script 1.8.7 (Updated)
Avast v4.8 Home Edition (Updated)

I will send my CFP configuration file, Reg Export, or other info on request to appropriate persons.


i dont know how to send a bug report, (i know the instructions are on the forum, but i am so lazy…) i can say exactly when CMDAGENT starts using 100% of your cpu even when using the latest version. just allow firefox to full its cache… when its full, cmdagent will lock up. thats it. if you always let it empty, wont freeze. thats what happens here. i think it happens when firefox try itself to clean its cache… just a thought.

I have verified that when I clear the cache the CPU usage goes to 100%. I allowed more than 1 hour and it remained at 100%. I am not sure if this is the same issue as my original post in this thread as the problem does not continue after a reboot. With the problem in my original post in this thread the problem continued as long as Used the original “Optimum Security” configuration I imported previous version exported before the problem(as a different Name) and it fixed it.

I will double check that it works in one config and not in the other and run a diff

However I can confirm the below send both My PCs to 100% with CFP v3 and Firefox. v3.0.4

Main>Options>Advanced>Offline storage box. hit the clear now button

I am running on the laptop that I have been using to duplicate the problem most frequently
CFP 3.5.55810.439 Firewall & D+ only (no AV)
Firefox ver 3.0.4 (Updated)
No-script 1.8.7 (Updated)
Avast v4.8 Home Edition (Updated)

That’s strange. clearing the cache worked fine for me.

I can say that the 100% happens in firefox when i load something very heavy, for example youtube videos… (my pc is slow… ) then no doubt cmdagent.exe goes 100%… but now i have a worst thing happenning:

i uninstalled the old version because it was 3.5.55810.432… i thougt “lets upgrade… its a good idea” now i installed the 3.5.57173.439… worked fine… but i got 100% cpu load even when just using Winamp!! i think is something about the rules because i uninstalled comodo… and when reinstalled, some questions like for example SVCHOST.EXE is trying to access…" well comodo didnt asked… ((ghost application database?)) maybe we need to do a full uninstal… comodo does this when uninstalling itself?

i’m using only comodo internet security and nothing else… i was using avast… but since CIS has AV i uninstalled it… my pc is a athlon 1.3ghz, 1 gig ram, geforce 2mx 400… an asus motherboard, windows xp sp2 32 bit… comodo always worked fine here… the only thing that sucks is cmdagent.exe using 100%.

well… so i tested it again… uninstalled the new version… cleared all the things… registry entrys/keys… folders related with the product. started working fine. but after storing some rules… 100% goes again. i think is something related to defense+rules… storing applications databases… or defense+ trying to figure something ‘new’…

i cant send a log because wow!! 100% on a athlon 1.3 gigz just sucks! i cant even make ctrl+alt+del… nothing freezes nothing stops working… just the cmdagent steals my processor power… lol!!

well… just a note… WHEN using only comodo firewall (an old version… its the version before CIS was released, the ) nothing bad happens.

ah how the bug happens - i just start windows… and after i start any application, 5 minutes later cmdagent.exe goes 100%.

if you want a 101 proccess… is this… do a full uninstall for CIS. then restart computer. clean everything related to CIS. now install it. restart the computer. start using CIS… Set the Defense + responses… after some time using CIS, it will go 100%… if you want more details, ask me. what i can say is that happens
only with the new verions… from 3.5.53896.424 up ++. even if you disable defense + cmdagent still go for 100% cpu usage…

I am still seeing CMDAgent go to 100% with firefox. I am running CIS v3.5.57173.432 x32. I completely uninstalled and reinstalled. All was runing fine until I ran Comodo Total System Utilities(CTSU) registry cleaner. I restored the registry and rebooted after system utilities corrupted my start menu header(a known bug with CTSU) Then when I tried to launch Firefox and the cpu went to 100%. As I said in my previous post this can be fixed by changing the configuration, however if I change back to my original Configuration firefox may run fine for a while but inevitably CMDAgent returns to 100% after launching Firefox. A complete uninstall and reinstall of CIS seeems to fix this problem. I have not tried clearing the Firefox cache to see if it causes a recurrence of the problem, as this was suggested as onepossible cause annd I verified it on a previous install of CIS.


JUst checkedand this does not currently send CMDAgent to 100%
Main>Options>Advanced>Offline storage box. hit the clear now button

I am running on the laptop that I have been using to duplicate the problem most frequently
CFP 3.5.55810.439 Firewall & D+ only (With AV Enabled)
Firefox ver 3.0.5 (Updated)
No-script 1.8.8 (Updated)
Yahoo toolbar
Zotero 1.0.9

I am also having this problem. It occurs every time I try to start firefox, as soon as the process starts cmdagent.exe goes to 100%. I will then have to wait very long time for firefox to load and it does not help to close firefox. When I close firefox or kill the entire process tree cmdagent.exe still uses 100% CPU. The only way to stop make it stop is to restart.

I am using:
Windows XP Home SP3
firefox v. 3.0.5
CIS v. 3.5.57173.439

Is this a new install or have you been running CIS w/ Firefox for a while.
What FF Addins are you using?
What other security software ie. Antispam, AV, other?
What is your CPU and Memory?

I have found several solutions see my previous posts
I think it might be a CIS configuration problem. or possibly a FF Addin Such as No-Script
If you have No-Script, before doing any thing try this

  1. disable D+ first I think this will stop the CPU problem i think
  2. Start Firefox
  3. Uninstall and reinstall No-Script
    or B
    Try Changing Configurations in CIS

I suggested (A) because I noticed something, I can’t remember what, last time that made think this might be the problem not because it worked for me.

Mine is running fine right now, a little delay starting FF but not bad.


I think it is something that needs to be fixed, but out of several million installs there are not that many posts. It has been reported as a previously fixed bug but I don’t think they have it right yet.

sounds like a bug that is so severe that it should be fixed.
100% cpu load is not fun. :frowning:

It DOES still exists. Starting to look alike “THE BLUE SCREEN OF DEATH”… Every update solves it, but it’s always back. Somehow, Firefox is connected to the issue. I tried to uninstall all of the add-ons and nothing happend. I cleared the cache before starting D+, sometimes help - sometimes not. I tried everything I read of, and results are the same. No problems with Safari, IE and Opera. If there is no problems with FF, they will soon start, almost whenever I run some other app while FF is running. Tried to look through D+ events, but little is recorded, except “NVMixer.exe-Access Memory-cmdagent.exe”.
Just hope I’ll have some time these days to dig deeper through the problem, that is if 100% CPU utilization allows me…

Actually I have been having this issue since the beta stage. but it did disappear for awhile in the 2nd beta build brfore the official launch. In my case it is usually the Firefox browser, but not limited to the program.

FIREFOX and COMODO = 100% (misfit)

I’m using Comodo (latest version) at least for 1 year with IE 6 and 7. Perfect!

Since 4 days I’m using Firefox (latest available) also and now, after 3 days the CMDAGENT grabs 100% for about 5 minutes after starting Firefox the 2nd time. Starting Firefox the 3rd time means loss of any control for ages or 10 minutes for a proper shutdown.

Do we have choice of Comodo or Firefox? Is there any bugfix in sight?

I’m using v3.5.57173.439 and have the same problem. I reinstalled the OS a week ago yesterday. I’m using XP Home SP2 w/ 1GB ram. It just happened 5 minutes ago. The CPU usage finally went down again. How can something that only uses 884K take up so much CPU?

I am totally fed up with cmdagent hogging my CPU. So much so that I am removing Comodo and going to Zone Alarm. If the whole idea of open source/free/GNU software is to encourage it, why haven’t Comodo sorted this out instead of forcing its users away from Firefox and back to IE??

Perhaps because there is obviously something else causing the problem?

I use Firefox and have noticed no weirdness in conjunction with Comodo.