Firefox Can't Access Internet If Started When PC Boots [NBZ]

The bug/issue

  1. What you did: Started Firefox within 30 secs of of startup of Win XP

  2. What actually happened or you actually saw: Firefox window took 4-5 minutes to appear, but all requests for web pages received reply “the server at xxx is taking too long to repond”

  3. What you expected to happen or see: Firefox window to appear within 2 minutes and webpages displayed. (Works OK at CIS 5.0 or with CIS 5.3 uninstalled).

  4. How you tried to fix it & what happened: Delayed Firefox start by 30 seconds. (Linkmonitor - a network monitoring programme I use - tests access to every 5 seconds This also failed to detect a good network connection unless its startup was delayed by >30 seconds).

  5. If it’s an application compatibility problem have you tried the application fixes here?: N/A

  6. Details & exact version of any application (except CIS) involved with download link: Firefox 3.6.13.

  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. Start Firefox from Win XP Startup Folder.

  8. Any other information (eg your guess regarding the cause, with reasons): Anvir Task Manager shows that Firefox process starts OK, but Firefox appears not to send or receive any network data, even after requests for webpages are sent.

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.174622.1216, 7353, default config

  2. a) Have you updated (without uninstall) from CIS 5.0: No. clean install of 5.3
    b) if so, have you tried reinstalling (if not please do)?: Yes

  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a preset config (if not please do)?: N/A

  4. Ave you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No

  5. Defense+, Sandbox, Firewall & AV security level: D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=Stateful

  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, ?, Admin account.

  7. Other security and utility software installed: None

  8. Virtual machine used: None

Can tell us what version of FF you are using? Did you try a clean installation of FF without extensions or run FF in its safe mode with extensions disabled?

Firefox 3.6.13 (as per bug report). Started FF in safe mode - still same problem.

It seems that CIS permanently denies access to the network, if (non-system) processes start too soon after PC boot (Anvir Task Manager shows that cmdagent.exe and svchost.exe access the network OK during this period).

This would explain why LinkMonitor also cannot access Todayy, CMail.exe (my email notification programme, which autostarts on boot up) did not work, saying it could not access its server - which it tries to access every 5 minutes.

When the processes do not work, if they are stopped and started again then they work OK.

The problem seems to be that - if certain processes start whilst CIS is initialising, CIS blocks their network access for their duration.

Does it reproduce when you do a clean install of FF in another folder?

Problem still the same at CIS v5.3.175888.1227. I’ve not done a clean install of FF in another folder - I don’t see what this would achieve, as the problem is affecting other programmes as well as Firefox.

For my understanding of the problem. If you start FF after the 30s delay, that is needed to get the internet connection released, does it still take 4-5 minutes for the FF windows to show up?

Do the same things happen with other applications? I mean:

  • when an application is started in the period where there is no connection does it take 4-5 minutes for the program’s window to show up?

  • when an application is started after the connection is released does it’s windows show up like you would expect?

If I delay the start of FF for 30s, it starts up normally (in about 30s) and works OK.

The other progs I mentioned (LinkMonitor or CMail) only appear on the taskbar. They appear in normal time, but can’t get internet responses if their start up is not delayed.

I’ve tried to start Comodo Dragon on boot up from the startup folder, but this has the same problem as FF:

  • Anvir shows CD’s active process immediately.
  • CD’s window doesn’t appear for 90s (shorter than FF, but then it normally appears much faster than FF).
  • Web pages cannot be displayed. They all return the error message “This web page is not available”.
  • Clicking on the link “More information on this error” gives the info
    Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error.
  • If I close and restart CD, it works OK.

I see. I assume using F5 or ctrl+F5 does not help when trying to get the browsers to work?

When you say “within 30 secs of of startup of Win XP” what do you mean? 30 s after the computer gets powered up, 30 s after the dekstop shows up, 30 s after the log in screen shows up…?

The same questions about “Firefox window took 4-5 minutes to appear” and " Firefox window to appear within 2 minutes".

First take of a possible short bug description: During boot time CIS greatly prolongs the start up time of applications that use the web, like a browser, when the time the internet connection has not been activated.

Refreshing webpages has no beneficial effect.

I’ve found that 45s is needed to guarantee the programmes work OK. I’m using “Startup Delayer” to delay the start of the browsers etc, so I suppose it is “within 45s after the desktop showing”.

Firefox (4-5m) and Dragon (90s) window appearance times are also timed from desktop showing (N.B. Anvir Task Manager shows their processes present, and active, immediately after the desktop is available).

CIS prevents that instance of the application process from ever accessing the internet. The application must be closed and restarted for it to connect to the internet.

Is the prolonged start up times for CD and FF because they try to establish a network link before attempting to display their window? (Link Monitor’s start time is normal, but still it cannot access

Short Description?: Web applications (e.g. browsers), if started soon after boot time, are denied access to the web.

Ive just udpated my wife’s PC (same spec) to CIS v5.3, via the CIS updater - and FF etc start & work OK.

After using the updater, her PC still retained the old CIS Network & Security Policies for the affected apps - whereas CIS has not asked/created any specific Policies for them (it was a clean install of CISv 5.3).

This might give a clue as to the cause of the problem.

Thank you for your bug report in the required format.

Moved to verified.

Thank you