Firefox 8.0.1 loads pages & links slowly

      I recently downloaded & installed Firefox 8.0.1 on 2 Windows XP Pro Sp3 p.c.s - One in my Office & the other at home . It seems to be running great on the Office p.c. (This one has Norton 360 installed on it & fewer Start-up Programs ) . However , on the home p.c. , (which has Avast (Free) & [b]Comodo Firewall (Free)[/b] installed plus quite a few Programs that get loaded on Start-up) ,  it takes anywhere between 10 seconds to about 2 minutes for pages or links on pages  to load .  Sometimes , a link on a page will not open even after waiting for 5 minutes . 

   I uninstalled firefox 8.0.1  with Revo uninstaller & then reinstalled it , but still the same thing happens .

Next , I tried running firefox after disabling Avast & Comodo Firewall (both together) but still the same thing . Even , after running Firefox in Mozilla Safe mode (with all plugins disabled) , the same thing happens .

    [b]However , If I start the Home P.C. in Windows Safe Mode or Windows Safe Mode with Networking ,  firefox loads everything very, very fast , almost instantaneously .[/b]

       The firefox plugins enabled on the 2 p.c.s are :-

Office p.c :-
.
1 .Adobe Acrobat 10.1.1.33
2. Java Deployment Toolkit 6.0.290.11
3. Java ™ Platform SE 6.0.290.11
4. Microsoft DRM 9.0.0.3250
5. Shockwave Flash 11.1.102.55
6. Shockwave for Director 11.6.3.633
7. Windows Media Player
Plugin Dynamic Link Library 3.0.2.628

Home p.c. :-

1 . Adobe Acrobat 10.1.1.33
2. Java Deployment Toolkit 6.0.290.11
3. Java ™ Platform SE 6.0.290.11
4. Microsoft DRM 9.0.0.4503
5. Shockwave Flash 11.0.1.152
6. Shockwave for Director Not installed
7. Windows Media Player
Plugin Dynamic Link Library 3.0.2.629

       However , I don't think the problem is significantly linked to Firerox plugins because even after disabling all of them on the home p.c. , firefox runs in the same slow way & pages or links take a bit of a time to open .         

      I started Windows in Safe Mode & then added the processes one by one from "Start - Run - cmd"  to find out that after the addition of which process  , Firefox 8.0.1 actually slows down . However , for 13 processes , I received the Error Message :- "<process name> is not recognized as an internal or external command, operable program or batch file" and so couldn't start those from "Start - Run - cmd" . These processes are as follows :- 

rundl32.exe
FLVsrvc.exe
VideoAccelerator.exe
Cpa_VA.exe
Apache.exe
cfp.exe
mysqld-nt.exe
AvastSvc.exe
cmdagent.exe
Ymsgr_tray.exe
Psiservice2.exe
jqs.exe
CLPS.exe

Any ideas , how can I further troubleshoot & zoom in on the trouble maker amongst these processes (Find out which one of them is making Firefox slow ) ?

[attachment deleted by admin]

What modules of Avast are you running?

About your Comodo installation. Do you have Firewall, D+ and Sandbox running?