Firefox 4 location bar search fail with Comodo firewall 5.3

I’m using Firefox 4, Windows XP SP2, Comodo Firewall 5.3

I just installed Comodo Firewall 5.3. When I try to use FF4 location bar search, there will appear a Comodo page that says, “Sorry, “(the search keyword” does not exist or could not be found.” There’s also a “suggested searches” on that page.

My FF4 config:about keyword.URL is set to Google already. This issue will only occur when I type in a single keyword. E.g. onelook. If I type in two or more keywords, e.g. “one look”, it will turn to Google search engine without problems. So the problem really is with single keyword search.

The single keyword search in the search bar on the right to the location bar in FF4 works fine. It’s just the location bar that’s having this issue.

Thank you for your help.

My email:

I’m not able to recreate this with default installs of CIS and fx 4, using Google as the keyword.url

can you supply any additional details

I upgraded to FF 4 from FF 3.6.16. Then installed Panda Cloud, then installed Comodo Firewall. I didn’t see any apparent conflict between Panda Cloud and Comodo Firewall. I only downloaded and installed the free Comodo Firewall, not the whole Comodo internet security suite.

Comodo Firewall current setting is: Firewall Security Level is “safe mode.” Defence+ Security Level is “safe mode.” Sandbox Security Level is “enabled.” Configuration is “COMODO - Proactive Security.” Full version info: Comodo Firewall 5.3.181415.1237.

In my original post described scenario, the location bar search error page is this (searched with keyword “onelook”):

My FF4 keyword.URL is set to “Google”. “browser.fixup.alternate.enabled” is turned to “false.”

Again, if I change my search keyword to “one look” and separate them to two words, there is no problem. It takes me to Google search. It’s only when I type in one single keyword search. I also tried inputting Chinese (traditional), and there was no problem. So the only case that has a problem is single English keyword search.

Curious, I still can’t reproduce (see image)

Are you entering the search string in keyword.url, with or without the quotes?

[attachment deleted by admin]

I suspect Secure DNS is playing up here, did you install Secure DNS during the setup of CFW?
It’s on by default. You can find more details here Free Comodo Secure DNS | Best DNS Security Solution 2022

I installed Comodo’s DNS servers during the install of CIS and can confirm they are being used. Possibly a regional thing?

[attachment deleted by admin]

@Radaghast: I entered keyword.URL search string without the quotation marks.

I recovered my computer entirely, re-downloaded FF4 and then Comodo Internet Security this time. The same problem occurs. I did chose to have Secure DNS in setup both times, and checked my DNS setting and confirmed.

So is there a way to still have Comodo Secure DNS on without this search issue?


Unfortunately, on a system with clean install of both Windows 7 or XP with XP 2, CIS 5.3 + DNS and firefox 4, all in default configurations, with only the Keyword.url change, I simply can’t reproduce the condition here :frowning:

The best I can offer is to try another DNS provider and see if the problem continues:

ClearCloud DNS
Norton DNS

Can you please post your OS version and Language your using?
Maybe it’s some kind of language v.s. Secure DNS issue

After you solve this issue upgrade to SP3.
Microsoft doesn’t support SP2 any more.

I think it is a DNS issue as well, I agree with the Norton DNS suggestion/recommendation.

Norton DNS

Their Support Forum is mixed in with Other Norton Products and can be found here:

Their Support E-mail Address is:


Good luck. :slight_smile:

I too am having this EXACT same problem. For me, it won’t allow me to access about.config in FireFox. It takes me to the same page.

It’s disheartening to see that no one has arrived at the root of this problem. I’m not running Panda Cloud but do have FireFox 4 installed on Windows 7. It takes me to the same page described above that reads, “Sorry, “about.config” does not exist or could not be found”.

Here’s the URL it gives me:

Help please. [bump!]

You do know it’s actually ‘about [colon] config’ and not ‘about [period] config’?

I was having the exact same problem, and for me it was a DNS setting

1-go to Start > Control Panel > View Network Status and Tasks
2-in the second “section” (under view your active networks) click on the Connection name beside Connection:
3-in the popup, click properties.
4-click internet protocol version 4, then click on properties
5-select the option to “Obtain DNS server address automatically” (the DNS server locations that are entered are from comodo)
6-click ok.

This worked for me, not only can I search normally like I used to, but comodo still works ^-^

Good luck!