Firefox 36 since update comodo blocks ONE kind of attempt

Since i updated to firefox 36, comodo blocks continously attempts of firefox to connect to
from port 1900 to port 1900
destination 239.255.255.250

WITHOUT question.
Every 2 minutes two attempts.

As long as firefox is running.
I erased the former rule, and gave firefox the web browser rule again. It doesnt stop.

https://www.grc.com/port_1900.htm

Perhaps related to UPnP? But what would Firefox need that for?

Edit: Or perhaps specifically SSDP? Simple Service Discovery Protocol - Wikipedia

I updated the portable firefox i have as well, to test what happens.

It isnt affected.
So what does this mean?

Not sure, I don’t use Firefox myself, but I found a discussion with more info here: Which service - fx36 and up - is responsible for SSDP? • mozillaZine Forums

Yes, i just found that as well.

So do we have a questionable function in firefox here,
or does the rule of comodo doesnt fit?

How to disable that function? Every two minutes without reason…

The web browser rule of comodo doesnt fit anymore to firefox.
No matter if the function of firefox is justified or not.

Would the web browser rule give any kind of security, or is it just so people easily get a web browser to work?
If firefox needed such a rule to be safe, you should not use the program.
So for now, outgoing only is the way to go.

It’s probably part of that new configuration-less conversation thing they integrated from Telefonica.

I hate this kinda of bloatware. I want a web browser, not skype.

That doesnt look like the reason

I don’t have such a problem with Comodo 8 and FF 36 under Windows 8.1 x64.

Because you dont use the predefined policy of web browser for it.

You should be kidding me!
Guess what - I am using exactly the predefined web browser settings for firefox.exe and I don’t see a single event related to firefox in the firewall log.
I don’t care if you believe me or not. :slight_smile:

Regards,
G.

That just proves that your firewall is not set to ask about this kind of different connection, when you allow any other.

Check if the web browser rule covers this traffic,
then come back here.

My settings are fine…




and firefox is not trying to connect to 239.255.255.250 regarding (currports, tcpview or netstat)…

Which firefox do you use?
What alarm setting do you use for firewall? (Ask for each port, each ip, each protocol, highest alarm setting?)

Btw, since the nightly build of firefox there are reports of this behaviour in combination with comodo.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2911235

I am using Mozilla Firefox 36 Final. Before I was on the beta channel 36 beta I and updated Mozilla from the offline installer (if that make some sense).
On my work computer Mozilla Firefox automatically updated itself from 35.0.1 Final to 36 and then Windows Firewall displayed the following message: “Windows Firewall has blocked some functions of this program.” Unfortunately I didn’t have the time to check further.

Also I have a lot of services disabled (like file and printer sharing, server service, ssdp discovery, netbios over tcp etc.) and I always uninstall Mozilla Maintenance Service from the Control Panel and maybe that does the difference.

What alarm setting do you use for firewall? (Ask for each port, each ip, each protocol, highest alarm setting?)

Did you ever check the screenshots in my previous post. :slight_smile:

Let me start by saying that I am not very knowledgeable about Firewall activity, but am learning. I am having a similar issue with incoming requests via port 1900.

It started with Comodo asking me if I wanted to allow Svchost.ext to receive a connection from 192.168.1.254 - UDP, Port 1900. I allowed it at first, because I recognized the ip address as my router and figured it was just “checking in.” Then I had second thoughts when I noticed it was from port 1900, as I had never received this type of request from Comodo before. I terminated the connection within Comodo with no ill effects. I also received another request for svchost.exe, port 51494, which I blocked.

A little while later I received the same type of message, only it was FireFox that was doing the receiving, from 192.168.1.238 - UDP, Port: upnp - mcast(1900). I don’t know what device this is from - there’s nothing in my router log pertaining to it, even though it appears to be local. At first I accepted it, but again, had second thoughts so I terminated it.

I hope I didn’t mess up by accepting those two connections - I terminated them within 5 minutes max. Can someone advise me?? Any help is appreciated!

I have those services disabled as well.

But the point is, the web browser policy of comodo does not cover these connections, so they are blocked. Something of firefox 36 does make these connections. On start up, and each 2 minutes.
As well described in the forum post i linked.

If you dont need unrequested ingoing traffic, i would recommend to use the stealth port function, hide from everyone. That will block unrequested ingoing traffic, so you dont have to wonder each time.

For the traffic that firefox creates, well, i use the outgoing only rule for it now. Firefox should know what it does. Right? :smiley:

I was able to catch the following from my main pc:

[quote]

Process Name : firefox.exe
Process ID : 1116
Protocol : UDP
Local Port : 1900
Local Port Name : ssdp
Local Address : 0.0.0.0
Remote Port :
Remote Port Name :
Remote Address :
Remote Host Name :
State :
Process Path : C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Product Name : Firefox
File Description : Firefox
File Version : 36.0
Company : Mozilla Corporation
Process Created On: 2.3.2015 г. 22:22:16
User Name : B-BOY-PC\FFreestyleRR
Process Services :
Process Attributes: A
Added On : 2.3.2015 г. 22:34:19
Module Filename :
Remote IP Country :
Window Title : Firefox 36 since update comodo blocks ONE kind of attempt - Firewall Help - CIS | Page 2 - Mozilla Firefox

But it quickly disappeared and didn’t appear again for almost 20 min. now. Still nothing in the firewall log and the logging is enabled.

What happens if you start firefox and look at connections in the usual window of comodo?
Do you see a note about firefox using 1900?

Why wouldnt it be blocked by using web browser rule set in your case?