Firefox 3.x & Gmail: incompatibility with Comodo AV?

Approximately a month ago, I started noticing that when loading Gmail in Firefox 3.5, my browser would hang for approx 30-60 secs, and then Gmail would function correctly until the next time that I reloaded the page or opened the account. The problem became more frequent.

I downgraded to Firefox no change.
I rebooted my cable modem and router, twice: no change
I then uninstalled Comodo IS: no change.
I then reinstalled Windows with a reformat. I reinstalled Firefox 3.5 and used only Windows Firewall: no change.
I then reflashed my router’s firmware, twice: no change.
I then reinstalled Comodo IS (both firewall and AV): no change

Then, I checked a very similar computer on my home network that I use only for a security system. It had the same basic setup as the computer in question with one major exception: only the firewall part of Comodo is installed. There were no Gmail hang-ups.

I then uninstalled the Comodo suite and reinstalled only Comodo Firewall.

The results were improved but I still had an occasional hang.

I then changed the “Defense + Security Level” to disabled. Since that time I have had no further hangs.

A possible conclusion: Comodo AV was interfering with loading Gmail. I realize that all the actions above are not consistent with this conclusion but there is no unifying theory that explains everything except some problem with Gmail that got better at the same time that I disabled the AV. That’s not likely. Additionally I didn’t clear the Firefox cache after every phase of the experiment until the latter parts. That could explain why there may have been some hangover from phase to phase.

Anyone else with thoughts here?

The ultimate experiment would be to reinstall the full Comodo suite and see what occurs. I may do so, but not until I have had a trouble-free period with Gmail for about two weeks.


AMD 9950 quad core proc on Asus motherboard
Windows XP SP3 32-bit
Fast cable connection


PS No hangs occurred with IE or Chrome.

Austin TX

Usually my first hunch would be that this a browser issue. So first thing to do would be to see if browser can be excluded as the cause. Unfortunately I don’t have a G Mail email account so I could test under Win 7 RC to see what happens.

When you reinstalled Windows and installed FF 3.5 did you import any old preferences or extensions? Can you reproduce this with a total clean installation of FF without extensions?

I am not a FF user so I don’t know the exact procedure to clean install. Yet, make sure to delete all the profile related information under Documents and Settings and Program Files after uninstalling. Then clean your registry with a thorough registry cleaner. Or try Revo Uninstaller in advanced mode.

Does the same problem still occur?

When the above doesn’t help. What other security programs are running in the background? Try disabling them and see if that helps or not.

I’m a bit at a loss as to why you feel CIS has anything to do with your problem if you reformatted your drive and reinstalled windows and the problem still occurred on this fresh install with only the Windows firewall. That would be pretty definitive proof that CIS has absolutely nothing to do with it… ???

Why did disabling D+ seem to stop the hangs? Coincidence! Something completely unrelated was at play here because as you’ve shown by your reformat and OS reinstall, the problem still existed when there was no trace of CIS on your system.

All that aside, I’ve been running CIS since version 3.5 and have never had any problems with Gmail in Firefox. (Currently running FF 3.5.1)

Do you still have these hangs if you run the basic HTML version of the page?

As I said clearly, everything is NOT consistent with Comodo causing any problems.

Since my last post, I have narrowed the issue down further to Roboform and Firefox.

I contacted the Roboform folks who actually acknowledged a problem with Roboform, Firefox and Gmail. According to the Roboform tech support reply, the issue I am having will be fixed in the next release of Roboform.

Thanks for your consideration of this issue. I have reinstalled CIS and uninstalled Roboform. I am using LastPass as my password manager with Firefox now.

Interesting. I also use Roboform and haven’t had any issues, but I never actually use Roboform to log in to my Gmail accounts which could be the difference. I use the Gmail Manager extension. When it tells me I have some mail, I just click the icon in my taskbar and it opens that Gmail account in a new tab.


I am new to this forum, but I came here for a similar reason.

I use Firefox 3.5.3, and Gmail and Comodo. I think that I have both the firewall and Defense + running. I use both Gmail and Yahoo email. Only with Gmail, do I have a problem. I have not had any hanging problems, but when I compose a new email and try to send, the sending does not happen ! Also, when I want to change from the inbox to another window, it does not happen. I have waited 10+ minutes before I gave up with the “Still Working” icon flashing. I have used my Gmail account on a different computer and it functions normally using Win XP and a different firewall and virus software. I assumed that I might have some setting causing the problem. I have checked all of the settings in Firefox that I understand, but I do not understand many of the setting in Comodo.

The firewall security level is set to Custom Policy Mode. I do not know how to check the security level of Defense +.

Any thoughts are very welcome.

Thanks, Doug

To see if firewall settings play a role disable the firewall temporarily. This can be easiest done from the systray by right clicking on the CIS icon → Firewall Security Level → Set to disable. You will also see Defense + Security Level; can you see how this is set?

When you are not behind a router switch on Windows Firewall before disabling CIS because otherwise you will be open for the world.

Let us know if disabling the firewall got rid of the problem.

Don’t forget to enable the Firewall again after testing. CIS will not warn every 15 or so minutes.

Hi Eric,

Thanks for the response. Yes, I found the window and the security levels. I am embarrassed that I forgot the section below was for the Dense+ portion of Comodo. I tried what you said, and there was no change to Gmail operation. Actually, I could not launch Gmail from the bookmark. I had to get in through Google Maps and then the link to Gmail. Strange !

I tried a couple of Test emails to myself. They went through, but within the Compose window, Gmail was telling me the it was “Loading” and then “Still Working”. I stopped Gmail after 5 minutes. Had to restart Gmail and then found the Test emails had been delivered.

I had Defense+ security level set at Paranoid. I have reduced it to Safe, but that did not change Gmail operation either. What is Defense+ ? Is it for virus protection or spyware [malware] protection or both ? Should I turn off Windows Security ? I really do not trust them. I had a friend that has made me paranoid about viruses and a lack of trust for Microsoft.

Thanks again, Doug

Please put D+ to Safe Mode and delete the rules you made for your browsers in D+. You can find the Application Rules of D+ under: Defense + → Advanced → Computer Security → delete the rules you made for your browser(s).

What do you mean with Windows Security? What other security programs do you have installed and running in the background?

Hi Eric,

I have Defense+ in the Safe Mode.

I looked at the Rules → Computer Security Policy - I do not understand anything that I am looking at. The only thing I see is a bunch of application paths, and a column Treat As - all the treat as are either ‘Custom Policy’ or ‘Installer or Updater’. There are about 13 screens in this window ! I am assuming that they are put there automatically by Comodo. Should I purge the entire file ?

Windows Security - I meant the built in Windows firewall and malware that are turned on within ‘Windows Security’, accessible from the Control Panel. I tried to turn those programs off, but I had no success. I am using Malwarebytes and I also have AVG Free running. Are these compatible with Comodo or should I delete either of these programs ?

We have a Dell Inspirion - Intel Core 2, 64 bit processor.

Thanks again for your help, Doug

You should definitely turn off the Windows firewall. You shouldn’t run two software firewalls. Also, if any of the other security applications have any real-time scanning features, you should disable those on all but one application. If you have multiple applications trying to do the same thing, (scanning files real-time) you can definitely run into trouble.

Do I understand correctly that you didn’t delete the rule for Firefox in D+? Please do and try again.

Does the same thing happen in the latest stable release of FF?

Hi Eric,

In Defense+, I just deleted everything that referred to Firefox. Sending email is still not working. Gmail will let me switch between inbox, draft, etc when it would not make the switch previously. Some success, but not functioning email as yet.

This computer came with McAfee. I just deleted the entire program.

I finally was able to turn off MS Firewall, so now I am strictly running on Comodo.

Any other thoughts to get Gmail working ?

Firefox Version - Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20090824 Firefox/3.5.3

I assume this is a stable version. I really do not know anything more. I am pretty sure this is the latest version and update.

Thanks, Doug

Sorry for the misunderstanding about the used FF version. My bad here.

Do you use Roboform like topic starter does? Also try a clean install of your FF without any extensions and see if the problem persists or not. The type behaviour you describe is most likely browser related.

You could also try starting Firefox in its safe mode to see if it’s an extension issue.

I’m running the same version of Firefox (as well as Roboform as the OP mentions) and I don’t have issues with Gmail, so there is no inherent incompatibility with CIS/Firefox/Gmail. I run D+ and the firewall in safe mode with the internet security configuration.