FireFox 3.0.5 & Error code: sec_error_unknown_issuer

I’m getting the following error when viewing my site with firefox 3.0.5

The certificate is not trusted because the issuer certificate is unknown.
(Error code: sec_error_unknown_issuer)

It works fine in IE6, IE7, Chrome etc…

Any ideas why I’m getting this error ?

Could you provide us with your website?


This is because your root and intermediate certificates are not installed.

Please follow this documention to install the certificate on cPanel 11. You might want to start with step 9.

and download this file, which contains the intermediates your web server needs.

The links provided are not working for me.

Please try again. I just edited the right ones in. It was my mistake.

thank you. … saved me a fixer post. (:NRD)

Trim this topic as needed.

I’m having the same FireFox 3 problem not only on my website at, but also the comodo https site. (:SAD)

From what I can tell you are showing secure and nonsecure content on the site. This results in the prompt when loading the site.

example cause:

TrustLogo Html Builder Code:
Shows the logo at URL
Logo type is  ("SC4")
Floating on the Bottom Left
<a href="" id="comodoTL">SSL</a>
<script type="text/javascript">TrustLogo("", "SC4", "bottomleft");</script>

The urls need to have https://

The firefox error I get @ your site is as follows.

You have requested an encrypted page that contains some unencrypted information. Information that you see or enter on this page could easily be read by a third party.

This has to do with the above code example. Make sure all content that you are showing on your site is coming from an https://

post back if you have any other issues.

I forgot to ask … Are you trying to have every page secure?

Hello Pixelus, I thought I replied yesterday, but I don’t see it so. . .
Thank you for your comments and suggestions. I think I have fixed the errant images now, but that wasn’t the problem for which I’m seeking a solution. (Also, no, I don’t want all pages on the site to be https.)
I’m having a situation where Firefox 3.0.5 doesn’t allow any access to secure sites using Comodo and the error message I get is the same one you posted.
Hopefully Comodo will have a solution for this. :THNK

Sal Amander posted fix above.

Get with your host provider and link them to the information Sal posted.

I submitted a support ticket to my host provider linking them to Sal’s post. They re-installed my cert and bamm it was fixed.

Most likely cause of problem → intermediates which are available in the download file Sal linked to.

This will not help Willow1 as they’re having problems even logging into site and other sites that use AddTrust External CA as the root certificate.

I have done the necessary checks and their server is presenting the certificate properly. I am currently working with Willow1 through the Comodo Support ticket system.

I am having the same Firefox issue with when the secure pages are invoked by attempting to check out - works fine in Opera and IE7. I am on Fluid hosting which uses H-Sphere control panel.

Thinking that there was a problem with the cert, I just requested a replacement.

Thank you.

We are getting the same error message with our hosting provider. We have used PC’s with Windows 7, Vista and XP all with different version of FF ranging from 3.0.5 to 3.0.19 but we keep getting this error message. Our Host keeps saying that its working on their end and its something to do with our cache. We have asked colleagues on different networks to try it out and they get the same error. Our host finally agreed to re-install the cert, but we are still getting the same error message. Can someone at comodo please help out. The server URL is

and the error is
Error code: sec_error_unknown_issuer

If you get the same error on FF, please post it here so that I can redirect my host to this forum so that they may see for themselves that the problem is not just with our computer and our client computers.


Certificate chain
0 s:/OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=*
i:/C=GB/ST=Greater Manchester/L=Salford/O=Comodo CA Limited/CN=PositiveSSL CA

There are certificates missing in the certificate chain/certification path. Your host needs to install the intermediate(s) for this cert to work properly.


The SSL Certificate works great with all browsers except FireFox,
which gives this for some reason: Error code: sec_error_unknown_issuer

Any idea why?

It seems that you have a GeoTrust certificate. Unfortunately most of us are not aware of GeoTrust’s SSL certificate hierarchies. However, I would suspect it is the same issue throughout this thread… Missing Intermediates.