Filter web not import list the terms *. correctly for websites [M1055]

A. THE BUG/ISSUE (Varies from issue to issue)

  • Summary - Give a clear summary in the topic subject, NOT here.
  • Can U reproduce the problem & if so how reliably?:
    Yes, always.
    Importing text files (this is the type of file that the web filter to recognize the import of configuration) with the characters *.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Make a clean install of the OS and CIS
    2:Create a category of websites
    3:Import a text file, for example containing the term *
    4:Note that CIS does not recognize the character *
    5:The setting will only be recognized after clicking edit each term added to the existing text file. (see video, images, attachments to the configuration, and the text file, for clarification)
  • If not obvious, what U expected to happen:
    The program should recognize the character (*) correctly when importing a text file.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Comodo does not seem to recognize or save custom settings of web filter, even on a clean install
    Even on a clean installation of the operating system without any modification but the error still persists.

See the following videos for a demonstration of this issue.


  • Exact CIS version & configuration:
    CIS 7.0.317799.4142
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default configuration
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Home Premium Service Pack 1 x64, UAC deactivated, Admin Account, Not a VM
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Avast, Zemana AntiLogger Free b=None

[attachment deleted by admin]

If I am understanding this correctly, the issue is that if rules in the form of *. are used that after saving it the Web filter does not correctly use the rule. However, rules in the form of * work fine. Is that correct?

If that is correct then please make some formatting edits to your first post. Please copy and paste the format from here into your first post. Then just replace the question marks with your responses. Do not make any other changes to the formatting code.

Let me know if you have any questions.

Thank you.

liosant, is my understanding of this issue correct? Also, please do make the formatting changes I recommended. Let me know if you have any questions.

Thank you.

PM reminder sent.

I will now move this to the Incomplete Issue Reports board.

Topics in this board are not looked at by the devs. The reason is that putting bug reports in the required format, with the required files, ensures that the devs have enough information to understand and identify the bug.

To get your report forwarded to the devs please put your post in the requested format. Also, pleaes clarify whether I am correctly understanding the reported issue. Once I have that I should be able to forward this directly to the devs.

If you have any questions please do not hesitate to ask.

Thank you.

Thank you for editing the first post. I made some more changes. For future reference just copy and paste the formatting code. Then replace the question marks with your responses. There is no need to edit the formatting manually. Please let me know if everything in the first post looks correct.

I did edit it so that it is specific to the default configuration configuration, which you said you encountered this with. The reason for this is that default configuration is easier for the devs to test. Thus, it just made sense to only use that example for the bug report.

Let me know if you have any questions.

Thank you.

I do some more change or recreate the report to correct?

Are you able to edit the first post in this section of the forum? If so you can edit the post yourself, although please be careful that you do not alter the formatting.

If it is not possible for you to edit the first post please just let me know what should be changed in your next reply.


I tried. Maybe watching the video better understand the fact.

Sorry my english!

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Bug fixed in the beta version of Comodo Internet security 8.0.332922.4281 :-TU

Thanks for testing this. I’ve now closed this entry in the tracker and moved this report to Resolved. If this issue returns please respond to this topic and let me know.

Thank you.