Files On Ext Drives Not Monitored In The Same Way As Files On C-Drive [M923]

A. THE BUG/ISSUE (Varies from issue to issue)

  • Summary - monitor program installation directory outside of reading and writing…
  • Can U reproduce the problem & if so how reliably?:
    Yes.every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Copy the same file (for example test.txt)copy to a different disk,a copy to the c:\ ,a copy to the f:.
    2:Set Comodo Firewall defense+ hips to paranoid mode.
    3:When you open the file C:\test.txt and f:\test.txt, no pop-up warning.
  • If not obvious, what U expected to happen:
    I hope to increase function: to monitor program installation directory outside of reading and writing.
  • If a software compatibility problem have U tried the conflict FAQ?:
    No
  • Any software except CIS/OS involved? If so - name, & exact version:
    NA
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    None

B. YOUR SETUP

  • Exact CIS version & configuration:
    Comodo Firewall 7.0.315459.4132
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Comodo Firewall defense+ hips set to paranoid mode. Firewall set to Custom ruleset. Autosandbox/BBlocker is disabled.
  • Have U made any other changes to the default config? (egs here.):
    no
  • Have U updated (without uninstall) from a CIS 5?:
    no
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    yes
    [/li]- Have U imported a config from a previous version of CIS:
    no.
    [li]if so, have U tried a standard config - if not please do:
    yes
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    This is seen on two computers.
    1.Win XP sp2 x64 fully updated, integrated IE8, and delete ie8 directory in C:\Program Files and C:\Program Files (x86)。Admin, No VM.
    2.Win XP sp3 x32 fully updated, integrated IE8, and delete ie8 directory in C:\Program Files。Admin, No VM.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=avast free 2014.9.0.2013 b=None
    [/list]

[attachment deleted by admin]

Thank you for reporting this. I have edited your first post slightly. Please look it over and make sure that all of the information is correct.

Also, please let me know which AV products you had installed on your system in the past, even if they are now removed.
In addition, please create and attach a diagnostics report to your first post. If you have any questions about how to do that please feel free to ask.

Thank you.

You are very correct understand what I mean。
But I don’t understand the following:
1.what is AV products?Refers to the video card?
2.diagnostics report to my first post? Can help an example?

AV is short for antivirus.

To create the diagnostics report open up the main CIS GUI. Then left-click on the question mark icon near the upper right side. Then select Support and then Diagnostics. This will run the diagnostics and then offer you the option to have it create a diagnostics report. Have it make a diagnostics report. Then attach this report to your first post.

If you have any other questions please feel free to ask.

Thank you.

Thank you.
1.AV products:avast free antivirus 2014.9.0.2013
2.The attachment。

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have asked me to request that you take a screenshot of the warning you experience when the file is on the C-drive. Please attach this screenshot to your next reply.

Thanks.

Please attach the screenshot, and provide any additional information.

Thank you.

1.Preparing the environment:open execl, and put test.xls in c: ,see picture 11.png
2.Click to open the file,A warning appears:see 12.png
3.Click “allow” on warning,then open c:\test.xls,now no warning appears.
4.show what in the test.xls.

[attachment deleted by admin]

1.Preparing the environment:open execl, and put test.xls in c: ,see picture 11.png
2.Click to open the file,A warning appears:see 12.png
3.Click “allow” on warning,then open c:\test.xls,now no warning appears. see 13.png
4.show what in the test.xls.see 14.png

[attachment deleted by admin]

Test method is more simple:

A. THE BUG/ISSUE (Varies from issue to issue)
Summary - monitor program installation directory outside of reading and writing…
Can U reproduce the problem & if so how reliably?:
Yes.every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:Copy the same file (for example test.txt)copy to a different disk,a copy to the c disk,a copy to the f:\1\1\ disk path, a copy to f:.
2:Set Comodo Firewall defense+ hips to paranoid mode.
3:Note that when you open the copy on the C:\test.txt and f:\test.txt,a pop-up alert appears, but when it is opened on the f:\1\1\test.txt there is no pop-up warning.
If not obvious, what U expected to happen:
I hope to increase function: to monitor program installation directory outside of reading and writing.
If a software compatibility problem have U tried the conflict FAQ?:
No
Any software except CIS/OS involved? If so - name, & exact version:
NA
Any other information, eg your guess at the cause, how U tried to fix it etc:
None

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Firewall 6.3.302093.2976
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Comodo Firewall defense+ hips set to paranoid mode. Firewall set to Custom ruleset. Autosandbox/BBlocker is disabled.
Have U made any other changes to the default config? (egs here.):
no
Have U updated (without uninstall) from a CIS 5?:
no
if so, have U tried a a clean reinstall - if not please do?:
yes
Have U imported a config from a previous version of CIS:
no.
if so, have U tried a standard config - if not please do:
yes
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win XP sp3 x32 fully updated, integrated IE8, and delete ie8 directory in C:\Program Files。Admin, No VM.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=avast free 2014.9.0.2016 b=None

Comodo Firewall 7.0.313494.4115 can not finish the instll on my Win XP sp3 x32,so only test on Comodo Firewall 6.3.302093.2976.

To reopen this with the devs I will not to be sure it still occurs for CIS V7.

Please try reinstalling by following the advice I give in this post. Then, see if after that V7 can be installed.

Let me know what happens.

Thanks.

A. THE BUG/ISSUE (Varies from issue to issue)
Summary - monitor program installation directory outside of reading and writing…
Can U reproduce the problem & if so how reliably?:
Yes.every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1:Copy the same file (for example test.txt)copy to a different disk,a copy to the c:\ ,a copy to the f:.
2:Set Comodo Firewall defense+ hips to paranoid mode.
3:when you open the file C:\test.txt and f:\test.txt, no pop-up warning.
If not obvious, what U expected to happen:
I hope to increase function: to monitor program installation directory outside of reading and writing.
If a software compatibility problem have U tried the conflict FAQ?:
No
Any software except CIS/OS involved? If so - name, & exact version:
NA
Any other information, eg your guess at the cause, how U tried to fix it etc:
None

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Firewall 7.0.315459.4132
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Comodo Firewall defense+ hips set to paranoid mode. Firewall set to Custom ruleset. Autosandbox/BBlocker is disabled.
Have U made any other changes to the default config? (egs here.):
no
Have U updated (without uninstall) from a CIS 5?:
no
if so, have U tried a a clean reinstall - if not please do?:
yes
Have U imported a config from a previous version of CIS:
no.
if so, have U tried a standard config - if not please do:
yes
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
1.Win XP sp2 x64 fully updated, integrated IE8, and delete ie8 directory in C:\Program Files and C:\Program Files (x86)。Admin, No VM.
2.Win XP sp3 x32 fully updated, integrated IE8, and delete ie8 directory in C:\Program Files。Admin, No VM.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=avast free 2014.9.0.2016 b=None

Thank you for checking this. I have updated the first post and updated the tracker.

Thanks again.

Under jiel‘s help,the problem seems solved.I use Security Settings->Defense±>HIPS->Protected Objects->Protected Files to solve. Thanks to jiel and Chiron.Very thanks.

Thank you for letting me know that this is now working correctly on your computer. I have closed this entry in the tracker and will move this report to Resolved. If the problem returns please let me know.

Thank you.