File & Printer sharing blocked by Commodo [RESOLVED]

I’m running a home network with a router, a desktop and a laptop (wireless connection), all Windows XP SP2. Both are running Commodo and Symantec (not Norton) AV with no other security software. Everything works fine if I only use the Windows firewall. The problem I have is that when I install Commodo on my desktop machine, I can’t access any files or my printer on the desktop from the laptop. I get an error message like:

\MAINMACHINE\SharedDocs is inaccessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
Not enough server storage is available to process this command.

This is a one-way problem. The desktop (or any other computer on the same home network) can fully access the laptop but not the other way around. When I open My Network Places on the laptop, I can see the shares on the desktop machine, but I can’t open anything.
Even disabling Commodo firewall doesn’t help – simply having it installed on the desktop causes the laptop to be cut off. I reinstalled Windows from scratch and I also installed a new LAN card today, but to no avail. I also made a Network zone for my home network IP range ( - and made rules to allow TCP and UDP in Network Security Policy > Global Rules. I also ran the Stealth Ports wizard to allow the Home Network zone, but nothing I do seems to make any difference. Commodo did automatically detect my network on both machines and I DID check the box to allow access from other computers. I didn’t have to change any settings on the laptop for it to work, but Commodo refuses to allow other machines access to the desktop machine. Can anyone help me with this, please?

I don’t think it’s a Comodo Firewall issue. I had the same problem before on XP. It was fixed by doing the procedure suggested at It worked even though the article mentions only Windows NT.

Thanks for the reply. Before I posted originally, I had already tried adding that registry key before and it didn’t make any difference by itself.
However, after I bought and installed a PCI network card (Corega) instead of using the built-in LAN on my motherboard and then added the key again everything began to work fine. I’m set it to what is supposedly the default value (15). Obviously that Microsoft article needs to be updated for XP SP2 as 15 is not the default or it would have worked to begin with.
So the problem had two causes: If I want to use Microsoft Networks, Commodo doesn’t work with the Marvell Yukon LAN on my motherboard, and for some reason my system needs that registry key set if I’m going to use Commodo. Problem solved.

Marked as Resolved. Thread Closed. If you need this thread reopened, Please PM Myself or another Mod with a link to the thread.