Feedback on Comodo Firewall

I will try and remain neutral, but my first impressions of this software are not positive!

I was enticed to download and use this software after the leaktest on your site. I admit to using Sygate PFW and figured it might be time to update since it’s no longer supported. What I wanted was a firewall with advanced rulesets so I could allow programs like Outlook to ‘only’ connect on port 110, or Internet apps to only use ports 80 and 443, rather than just have a yes/no system. Comodo seemed to meet these requirements. By saying I wanted to have a rules based firewall, I’m trying to show that I’m not the average home user that requires ‘point and click’ operation and will spend time setting up an application to do specific things.

So anyway, downloaded the installer, uninstalled Sygate (after burning an image of the files to CD) and rebooted. Confirmed that all references were removed from the registry and rebooted again. Installed the software using the power users options to limit the assumed default options. Rebooted (again!) and found that even though the firewall was alerting me to apps trying to access the net even when they were allowed, they could not connect. I also noted that my bluetooth and wireless network indicators had gone missing from the system tray. I tried launching Outlook and was prompted to use the dial-up connection that is reserved for when I am on the road and not at home (ie no wireless network to connect to) I tried setting the firewall to ‘allow all’, and nothing. I tried setting a rule to allow everything, nope! I tried exiting the application, still nothing. Even with the program not running I was still being blocked from the network. I uninstalled the program, rebooted and everything was fine again.

So I tried to reinstall using the default installation options. Same problem. I uninstalled, rebooted, read through all 20+ pages on the forum, got slightly worried about the problems this SWF has playing nicely with other apps, and tried again. This time I kept the default installation directory. Reboot, and at least now I can connect to the net.

Again I allowed or disallowed programs based on what the information in the pop-up window said, fixed the AVG problem and went to the test page on the Comodo website. Ran the test program and ■■■■ up comes the same web page as I had with Sygate (different text as I typed a different message) so it would seem that nothing has changed! Two minutes later I got the pop-up warning box. Bit late after the horse has already bolted!

I uninstalled the software, got a new copy of Sygate from Oldversions.com (thank heavens for archive sites!) and reinstalled Sygate. I copied the files from that backup CD back to my computer and now everything is running perfectly.

So my problems in summary:

  1. Very hard to install and get working, finally only managed it blindly clicking through the default options on the installation page.

  2. Firewall not compatible with AVG without a fix (the program will auto allow preset apps, so why not preset AVG with this little fix?!)

  3. With nothing changed from default (remember that was the only way I could get it to work!) it failed the very test that induced me to download it, so why should I have faith that it will do anything else it claims?

If I had paid for this software, I would be seeking a full refund for false advertising! Over the years, I have gone from McAfee Firewall (hey I was new to this then and an attempt at security is better than nothing!) ZoneAlarm Free, to Tiny (Kerio) PFW (I wanted the rules options that ZAF didn’t have) and now to Sygate. I have never had even so much as a hint of the trouble that this software caused and am just grateful that it was easily removed from my PC without any trouble (actually the only painless act in the whole experience!)

It’s a shame that this software left such a bad impression as I actually really liked the UI, but at the end of the day, looks come second to functionality. Amusingly, I don’t seem to be the only person having these problems, so it’s clearly not just my system configuration…