Fatal error 1603 when installing comodo firewall.

I have a problem when installing comodo firewall, it roll back action when it is installing kernel driver. After installation it has pop-up message with “error 1603” code.

I haven’t use comodo before and my computer can’t run combofix. I’ve already scan registry but it doesn’t work. Any ideas to solve this problem?? ??? ???

Thanks,
Wasit

There are a lot of people out there with the same problem, and me too.-
I tried two times now and spent many hours cleaning out system reg and folders, uninstalling my antivirus too, using all the posted cleaners, rebooting time and again. But when the big moment came, installation of the new CFP v4 using three different installers from Comodo, msi and exe files, the same roll back and error mess. occurred. For a few people it was successful to use the posted cleaners, though.-

I have now finally solved my problem with installing CFP v4-!!!

I used the CIS_clean up tool, the Comodo uninstall.zip file, and three different reg cleaners, and looked through the reg myself also to check randomly.
But I also remembered that “Spybot Search & Destroy” had tweaks to lock/protect some items-! and what probably did it was Comodos own Reg cleaner: CRC, it has a tick box in the settings that “protects” the registry!!! - I unticked it and checked with >regedit< that it was set accordingly.- VOILA-!!!-

There are some programs that offers to protect/lock the registry or zone settings or home pages in browsers, RAW Sockets a.s.o.- and with a firewall installation, which is very complex and needs to go deep into the heart of the OS and change crucially important configs and settings…-

     THEREFORE IT IS VERY IMPORTANT TO UNLOCK ALL THESE SETTINGS, ESPECIALLY REG LOCKS-

before installing firewalls or antispyware or other complex apps.

Also check for this reg key NOT to be present after your cleaning, it should be gone:

  HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Comodo Internet Security

I hope this will help some people with problems now that we don’t have any solution from the progammers that made it-!!