Fairly Major issue with CAV on fresh installations :\

I have been using comodo products for a while now, but since I have been upgrading machines to the beta 2, ive had nothing but issues, This is regardless of whether or not its an “upgrade”, fresh install of comodo or a full installation of windows + comodo.

The problems occurs with a combination of :
Windows XP pro or Media centre
Comodo Firewall
Comodo AV beta

First issue:

If I have the above installed, and then reboot after the final installation, regardless of what order they go in, I cannot then install any other program without the machine “hanging”.
I cannot kill the process of cavse as I dont have “permission” even though im the administrator.
I cannot kill explorer.exe as its “protected” by, (assuming) Comodo.
I cannot edit msconfig services as I dont have permissions (although logged in as Administrator)

If I disable CAV, then I can do any installation, but cannot kill the processes, or edit the msconfig services.

The second Problem, I cannot start Firefox , or Thunderbird IF CAV is running, once again the machine “hangs”.

As mentioned this is on, many variations of installation, and im loathed to carry on installing the software on the machines that I build for customers until I can find out what is going wrong. I currently have had to once again uninstall CAV from this machine as it was persistently hanging. Any help would be much appreciated.



This is a strange situation, Stevieb, and not one I think I’ve seen before. It sounds like there’s a serious conflict occurring, a problem within Windows, or something specific to the configuration you’re using. And that’s not much help, I know.

I’m going to see what input we can get here.


PS: I personally would not install CAVS 2.x on someone else’s production machine (especially for a customer) yet, as it is still technically a Beta (regardless of its stability on however many machines).

I know :expressionless:

I was installing the former CAV on customers machines most where using norton which i binned, then one day I logged on here, and it was only the beta I could find :frowning:

The first machine I installed it on there was no problems, nor on the second. both had no AV on there at all.

The next few have all had the issues i described above, the machine I use at home is the one ive reinstalled a number of times now, the latest was today. mainly down to it finally giving me the bsod, and totally not playing.

I reinstalled totally from scratch, including a low level format of the harddrive to make sure it was totally clean, and still the same issues.

This is an OEM windows Media Centre.

Are you installing in SafeMode? If not, I’d recommend doing so. Given the nature of security applications specifically (and the way they’re imbedding more deeply into a system to provide more security with less CPU time), there is a greater risk of conflicts during install & uninstall. I personally advocate the use of SafeMode for all installation-related procedures. Wouldn’t hurt to do some registry cleaning in between as well.


I tried installing in Safe mode today, and the same thing happens.
is there anything you guys can suggest that may help narrow down exactly what is causing the “hangs”, i know when I was beta testing other software they have some tracing extensions that will output to a more detailed log file, so I can try and locate what is going on with it all, the windows log files are as useful as a chocolate fireguard.



Let me see if I can get some input from the developers. Perhaps running psc-exam for an output will help (which I believe I can get to you if need be).


Using XP, Firefox, Thunderbird and never ever had any problems with CAV on any machines I have build/rebuilt for friends. It works just fine. Even friends I tell about Comodo never have any problems that you have listed.
It must be something on your machine(s) that your building thats cause these problems.
Are you installing dotnet frameworks, SP2 and other updates, drivers and everything else before installing Comodo? If not, you should try that.




I have changed slightly the configuration of hardware that I have been installing on the machines, and it “seems” to have resolved the problems.

I believe that its possibly the creative sound blaster audigy zs /mb drivers that are causing the issue, Im guessing at this as I have moved away from the creative sound systems to some cheaper ones on the last few machines I have built and they (touches wood) work fine.

again without knowing where to look / trace things its difficult in saying exactly what it is.



For what it’s worth I had issues too when I installed the CAVS beta on Win2K. On the 1st boot after the CAVS install Win2K locked up tight. I assumed and was expecting the program registration function at start up. I got something else instead. I don’t recall what it was but my machine was locked up for about 10 min. with no way out of it. I finally had to force a reboot via my soft boot button. On the next restart the prog registration function came up, did it’s thing and everything’s been fine ever since.

This all transpired in the admin account with Win2K fully up to date with all SP, patches, etc. Running Comodo firewall, FireFox T-Bird.

I haven’t provided much help, I know, but CAVS does seem to have some sort of conflict just after install. It’s like it’s trying to do something and something is preventing it. Maybe it’s trying to do things before the firewall, windows, or something is fully loaded or something?

I’m here only because I can hardly believe what’s happening after installing a trial of CAV1.1

After the first install my XPp box actually failed to start. “hal.dll is missing” and boot totally failed! Indeed hal.dll WAS missing - along with dozens of other files in sys32. Jeeezus!!

After extracting hal from the CD the box - 2GHz P4 - started at an utterly glacial pace - 30 secs for a right-click menu to pop up. It took days to bash and scrape CAV off the machine. Even then it complained. A repair reinstall of XPp was required and more kicking and scraping finally got CAV off.

I couldn’t believe CAV could REALLY be doing this so - heart in mouth - I put CAV11 back on - and guess what: it’s happened again!! When I started typing this entry I clicked okay on the problem box to restart it. It hasn’t happened yet!!

This really deserves its own thread. Comodo looks deader than dead… (:AGY)

[update] “CLPappGUI is not responding”. That’s why it took 5 minutes to begin to shut down. Grr.

JoeBleau I have posted a reply to your problem here:


Please do not post the same questions in more than one place on the forums, if a lot of users did this it would make the forums cluttered and difficult to manage.


the system i have used for years is as follows

build system
install windows
install drivers
do all M$ stupid updates, software, patches, drivers, optionals
install Firewall
install AV
install mozilla
install thunderbird
install adobe/flash/shockwave/java …etc

sort of at a loss now :frowning:

Hey stevieb,

I think you’re heading in the right direction in thinking it’s related to the SB drivers. There’s a myriad of posts about Audigy Live, Audigy FX, Audigy 2 ZS, Audigy CMSS-3D drivers crashing on a disparate range of MBs. The predominant complaints are crashes running under WinXP. Dell have released a BIOS upgrade to get around the issue as all current versions of SB Audigy drivers affect one Dell model.

As a test, I installed a ZS card in a system that has had CAVS2 Beta running for ages and it crashed badly. removed the ZS card, reinstalled the original, restored the system image and was back to normal.

I can’t find anything that I could call a definitive cause with any real confidence, but the weight of evidence, along with the fact that the problem went away with a different sound device, would seem to point the finger directly at Creative.

Now, they wouldn’t release shoddy drivers, would they? :wink:

hope this helps,
Ewen :slight_smile:

If you could forward the psc-exam to me I would greatly appreciate it, and would provide all feedback it would provide me, as I am having the same issue’s, I have done Clean Boot instal twice now after Numerous Lock-Ups of Explorer upon the attempted running of great programs such as Nero, Alcohol 120% even the Registry Bot reg cleaner, which I use after any major instal/un-install such as this. I have had no luck running this Anti-Virus solution since The second day. First day was fine, after that, things have looked bleak, It’s a two-headed dragon that I am not alone, good for the reason I am not alone, and Bad as it says a great deal about this Beta release. Obviously looking at their firewall solution it is possible for Comodo to do a great job in development and launch of a new product that works well…I am hoping this one gets its share of the attention as it is truly One of the most critical of all apps we run.