Failed to update the virus signature database

My version is the latest one 3.12… Comodo Internet Security The program in section miscellanius → check for updates updates normal but the antivirus database when I try to update tells me “Failed to update the virus signature database. Please check your Internet Connection and try later”. I tried to uninstall it and install it again NOTHING. I tried also older versions 3.5 and 3.9 but the same result. Please help me…

p.s.I am not behind a proxy or in a domain. Microsoft Windows Xp 32 bit SP3

Version 3.5 and 3.9 cannot have their AV database updated anymore because of a change in the AV database structure.

Did you install 3.12 as a clean install or as an update install? What other security programs do you have running in the background? Try disabling them and see if that helps.

When you did an update installation and the above did not help please try a clean installation. Uninstall, reboot and run this clean up tool. Now you can install CIS again.

I’ve also had numerous problems w/ updating. The software will, on occasion, update on its own, but I’ve never been able to manually update. With or without a proxy.

Currently on 3.11 but have the same problem on older versions as well.

Hey there,

I am in the “same boat” >:-D so to speak, I had come across a related post from a moderator that querried if windows defender was running. I do use this application, although the post never expanded on what the relationship between comodo and windows defender might be?

I have disabled, not uninstalled, Windows defender and I will post back if there is a change in the CIS updates status. I also followed a reccommendation to allow http://comodo.com I am using internet explorer 7, although I.E didnt like the address so added to the http://.comodo.com - the . being an addition.

Yeah,

Cav now upto date.

Allowed *.comodo.com in I.E and “let it run till its done”, was fine this morning… yay ;D

L8r

Since CIS doesn’t actually use IE to update, adding a safe zone to the browser wouldn’t have any effect. CIS only looks at your connection settings to see how you connect to the internet. It doesn’t actually use the browser.

Hey there, thats good to know, thanks HeffeD,

I was just trying various reccommendations, perhaps it just updates in its own time - as others have mentioned.

I even tried setting it to update prior to doing a scan and seemingly got nowhere and a manual update has never been successful for me. :stuck_out_tongue: ???

Thanks for the input

I have the same virus database update problem.

The program update works fine.

I tried to ununstall CIS and install the latest version (using clean-up tool before installation) and the problem still exists.

The strange thing is that when I check the about it tells me Virus Signature Database Version: 1.

Any ideas? %)

Hello,

I’m running CIS version 3.12.111745.560 and Updates Host is set to: http://download.comodo.com but, nevertheless, every time I try to update the AV database it stops at 5% and I get a message stating that “failed to update the virus signature database. Please check your internet connection and try again later”.

My database was never updated, so far. No problem with “check for updates” though - it works fine.

Thank you,
~/gnfpt

Please try a clean install of Comodo. After rebooting use this clean up tool to remove possible leftovers. Before uninstalling you can export your active configuration (Miscellaneous → Manage my configuration). You can import this configuration in the clean install.

Well I tried the following procedure:

  1. Uninstall Comodo Internet Security
  2. restart and run the clean up utility
  3. Dowload the new vesion of COMODO 3.12
  4. Clean INSTALL and Reboot

The Problem EXISTS. I cannot update the virus signature database. O0

Whats your type of connection?

Yah the same problem. 5% DB update fail and general program update works fine.

And tried clean install as well - didn’t help.

I use direct http connection (no proxy).

I run Windows XP with the latest updates and the latest version of CIS by the way. We have ~7 PCs with the same configuration and the problem is on my PC only %)

Maybe some important service is switched off? I remember I was playing with services…

I mean cable, or DSL, or 3G, or dialup…

I heard there maybe some problems with CAV’s and 3G network connections.

DSL

And it works just fine for other PCs using the same gateway.

Hmm, what type of accounts do you have on that PC?

All Admin?
Or some limited?

ADSL, one account administrator! I don’t know what to do anymore.

Same here

Do you guys have any Regestry Cleaners installed… Any system optimzers?
Do you have anyother security software
Also try turning Windows Firewall off.

@ xdimas
Check if you disabled Remote Procedure Call (RPC) Locator Service, i belive i heard CIS uses this.
Try turning each service back on and then checking if the AV will update.

After installing v.3.12 Comodo downloaded a huge database, 100mb, then it started to apply the definitions. The PC I was installing it was extremely slow=500Mhz ;D, it took a lot of time and I canceled it. Then the database got corrupted and nothing helped. Several times tried to update, and nothing happened. I’ve removed it and installed a fresh copy, then I gave comodo all the time and now is OK.