Failed to install Comodo Internet Security Premium due to invalid email address

I was using CIS version 3 previously, however after i received notification that new COMODO 4 is avalieable, i downloaded it. However my machine seems to be unable to install it since it keeps requesting for a valid email address which seems ridiculous. Please refer to my attachments. You can see on the 7th attachment, even after I keyed-in a valid email address, the installer still saying that it is not.

[attachment deleted by admin]

This email address is optional.

If you don’t enter anything there you should still be able to install.

yes Chiron, agree with you, it should be optional, but right now I cannot proceed with the installation with or without any email address.

Try downloading another installer. Maybe that one is corrupt.

Chiron, just did as what you advised, but still the same. FYI… the previous downloaded installer can be used for my Window Vista without any trouble

Which OS do you have?
Is it 32 bit or 64 bit? Also, which type of installer did you download (32 or 64)?

i hv 2 machines (both 32bit)

Installation on Vista - successful
Installation on XP SP2 - failed (revert back to COMODO 3.1)

Please try this methodology:
https://forums.comodo.com/install-setup-configuration-help-cis/how-to-upgrade-from-v3-to-v4-t58620.0.html
See if it helps on your XP computer.

Also, it seems that there may be some problems on SP2 computers. See this thread:
https://forums.comodo.com/install-setup-configuration-help-cis/most-stubborn-registry-ever-t57773.0.html;msg410616#msg410616

Is there a reason that you haven’t updated to SP3?

i can try those solutions…update to SP3, but it is just weird why must COMODO asks for email twice during Comodo 4 installation… (referring Screenshot 3 and 7)

May be it doesn’t like the dot in the name of the mail address?

ok…i am now using comodo 4 in my xp sp3 system…i do not know whether sp2/3 would be the problem, but i think i owe u guys the full story.

  1. I 1st tried to install ver 4 without uninstalling ver 3 (the same as what i did during my windows vista installation which was successful). After version 3 automatically uninstalled, comodo required system to be restarted before it can continues with the installation, which i did. However unlike my vista, before my xp manage to fully restarted, my spybot interjected the process by doing some scanning, after the scanning was done and my xp fully restarted, comodo installation did not continue. So then i decided to do clean installation and use uninstallation software developed by comodo. Which then I hit the email issue as reported. After multiple tried, i decided to reinstall ver 3 back, and it worked.

  2. As advised by Chiron, I updated my xp to sp3, and then continue with comdo 4 installation right after the same way I did as my vista. However this time during restart, my spybot did not interject and my system manage to restart and the installation continue smoothly. And now my xp is running Comodo 4 :slight_smile:

I would like to thank Chiron for the advise given. As for EricJH, sorry man, I just checked your entry after my comodo 4 installation was in progress, so did not get the chance to try it with another email address (without the dot). Anyway your help is very much appreciated as well. Probably others can try it if they had the same issue.

Thank you.

Thanks for reporting back.:slight_smile: