extremely slow boot up times


installed CPF on 3 of my pc’s at home. All of them are home-built and have not had any issues with any previous firewalls (have tried Kerio, LnS, Tiny, NetVeda, Jetico and ZoneAlarm). Just for the record these are all windows XP, 1GB-2GB ram, Pentium D 3.2Ghz\Opteron 165\AMD XP 2400+. I use Easy Uninstaller and Install Spy to completely remove all previous firewalls.

First one goes find with no issues. 2nd and 3rd one installs fine but on the reboot it brings the boot time to a crawl! One PC took 28mins and the other 34mins to get to the windows desktop. Up to the point where you have to log in the boot up is fine after that is where it slows down.

Only software that all of these PCs have in common (other then the OS) is Open Office 2, Avast AV and Windows Defender b2.

Subsequent reboots gives me the same slowdown. Reboot into safe mode ditto. Restart from last known good config same results. Remove CAV and boots up fine. Re-install and slow again.

Any ideas?

Did you try to uninstall Windows Defender and Avast and then try installing Comodo to see if perhaps it’s a combo of two? My guess would be Avast but I could be wrong. For the time being, use Comodo Anti V along with CPF and see how it goes.



I can only confirm, based on my own experience, that avast! AV has not been a problem with CPF (any version) running under W2k.

Well i have the same exact version of Avast on the one PC that installed fine. Its a good suggestion I’ll give it a try its just a very slow process with 30±min reboots.

Anyone else have any ideas? ???

The best thing to do first is as mentioned, uninstall AV and Windows defender, just install Comodo and see if you still have 30 minute boot up times. Try tapping the ESC button while waiting for progs to load. You may have something starting up that doesn’t like your firewall also. But as I stated, the best thing to do is single out Comodo on this machine, if it works fine with JUST Comodo, install the AV and see how it works. If it works fine, install Defender and see what happens, this is the easiest way to tell right now.



OK removed Avast and MS Defender, removed any application that I don’t really need, killed everything running at startup.

Boot times are now about 2-3 times slower then when CPF is not installed (running the beta right now) but at least its not taking 30+ mins so thats a big improvement. I’ve started to install apps back one at a time and rebooting between each and I’m thinking its the Avast.

No application could cause 30+ mins bootup. That is weird. I would say that PC needs a format.

I would agree with egemen. Another possibility I may add is that Avast or WD has corruption and may need to be reinstalled. I have had to do this for people many times, an application (for whatever strange binary reason) will cause issues when starting up with other apps from being corrupted. I would also run a chkdsk, defrag, clean up, and just to mention, what other programs are on the computer? 2-3 minutes is alright for a firewall and ZA used to take about 10 to 15 some days, depending how it felt I guess but Comodo is far faster. Windows Defender may be an issue and I don’t mean to sway you either way but I don’t use Windows Security anything as it tends to get in the way and doesn’t like other apps to run well with it. You do have your XP firewall LAN setting unchecked? File and print “checked”? Not just turned off? XP firewall can trick some into thinking it is completely off when it isn’t. It may be low ram, not sure what the specs on the PC are. When you have so many progs start up is it chewing up your ram? I am curious if WD and Comodo will give you this issue or if it’s in fact AV. If all else fails, your pc needs a good cleaning, or depending on resources, can’t handle the load, or as egemen said, a reinstall of the OS.


Sorry guys but this PC doesn’t need a format. applications can and do screw things up so that they slow down boot times. Like I said the pc boots fine up to the point that you have to log into the pc/network. Past the login your talking about drivers/applications/etc…

If I uninstall comodo or avast the boot problem goes away. I also read in the helpdesk that comodo had a similar problem with AVG (and I’m IMing two people i met on these forums who have the same problem with McAffe and NAV). So as a test I followed the instructions i found to get Comodo and AVG working (basically make sure all the AV .exe files are in the application monitor and then turn off "advanced security checks) for all of them.

Guess what? I do that and the PC loads fine. I turn on the advanced security checks and bam back to slow (don’t have time right now to do them one at a time).

Correct and why I stated this: Did you try to uninstall Windows Defender and Avast and then try installing Comodo to see if perhaps it’s a combo of two? My guess would be Avast but I could be wrong.

The rest were possible cause and fixes to mention, nothing definate.

Glad to hear you found the problem. :wink:



yeah im just confirming that Avast and CPF do have a problem working together as its caused extremely slow bootup on one system i installed it recently. I hope it gets fixed by the next 2.3 release as CPF does look very promising indeed :slight_smile:

I’m using Avast and Comodo Firewall BETA with no problems.

I’m also using avast! & CPF without any problems. But, I’ve also tested avast! & CPF without any problems either.

I’ve installed the official CPF on my work PC (a shiney new Dell Optiplex workstation, P4-2.8Ghz with 1Gb Ram).

The only security software loaded is NAV Corporate Edition.

After installation, I rebooted as requested. Where i used to boot to WinXP Pro in 20 seconds, it now takes 1-2 minutes to get passed the logon “verification” / profile loading.

I installed CPF with the default options and ran the Trusted Zone wizard. Manual reboot after doing that resulted in the same.

Are their any default options I should try disabling/enabling? Are their any logs I can provide?

This is about Terminal Sevices service(should be automatic). The issue has been fixed. Hopefully, we will issue an update on thursday(it was supposed to be today).

Thanks or the quick reply egemen. I was hoping it has something specific to do with being on a domain here at the office, and TS seems to fit that vein.

This new version… a new official, or new beta?

On a positive note… once windows is fully loaded the system is rock solid, fast, and behaves normally.

Nynan, have you checked your Comodo logs for any access denials due to policy violations? You may see something that will offer a clue to what is happening.

I have had a similar experience in the past, and it was not related to my firewall at all.

One morning I woke up, started my laptap and the booting phase took over 5 minutes to complete! This sequence would normally take no more than 40 seconds in the past on my WinXP Pro (SP2) laptop.

Suffice it to say that it took me nearly two weeks of agonizing experimentation to pinpoint the problem to a service called “Workstation”. This service was responsible for keeping my other programs (anti-virus, firewall, etc.) from loading in time, and that in turn was causing other erratic behavior.

So how did I discover that?

By doing this:

  1. During the boot up sequence (while you have just logged in, but Windows is still busy loading its stuff), use the “Run” command (from your Start menu) to fire up the “Services.msc” program.

  2. Once up, maximize its screen, and click on the “Status” column header to sort the lines.

  3. Visually locate the “Workstation” service, and see if it says: “Starting”.

  4. If the Workstation service is stuck with showing “Starting” for more than few seconds, then you know that you’re having a similar problem. (In my case it was responsible for hanging the system for over 4 minutes.)

before I go any further, please let me know if this is indeed what you’re experiencing.

Good luck.

Egemen, I have updated to (auto-update & then a complete uninstall & reinstall) and still have the same issue. I had found a reference in another post about creating application rules for lsass.exe with winlogon.exe as the parent, but these did not help either.

I have tried your suggestion and found that Workstation was Started when i opened Services.

OK. Here is another suggestion which should isolate the offending service responsible for stalling your system:

  1. During the bootup phase (which means as soon as you can click on the Start button, and click on the Run command), run the SERVICES.MSC

  2. Maximize its screen, and click on the Status column twice in order to sort the lines based on their loading order.

  3. Press the F5 key repeatedly (every second or so) to refresh the screen.

  4. You’ll note that as the services begin to run, their status changes to “Started”.

  5. Keep your eyes on any line which states “Starting” for too long.
    (Note the difference between “Starting” and “Started”)

That would be the service which is stalling your system.