explorer right-click context menu items disappeared in latest version


I have lost the two items

Scan with COMODO antivirus
Run in COMODO container

from the shellex explorer menu.

I tried the

regsvr32 “%ProgramFiles%\COMODO\COMODO Internet Security\cavshell.dll”

fix from here


but it just fails with an error 0x80070005 ( please see attached screengrab). This is ‘access denied’, but I ran the task as admin.

I tried going to Program & Features->Change/Uninstall->Repair

the Comodo diagnostics run and report no error.

I tried running regedt32 as Administrator to look at the Comodo key in

HKEY_CLASSES_ROOT*\shellex\ContextMenuHandlers\Comodo Antivirus

but it pops up an error box saying

Comodo Antivirus cannot be opened. An error is preventing this key from being opened. Details: Access is denied.

I assume this is Comodo protecting itself from tampering ?

How to get the repair done ? Looks like only Comodo tools have permissions to fix this ?

Comodo Internet Security Premium 10 version
Win 7 SP1 32-bit - fully patched

Thanks for reporting, team will get in touch.

Hi Habitformer,

The module "C:\Program Files\COMODO\COMODO Internet Security\cavshell.dll" was loaded but the call to DllRegisterServer failed with error code 0x80070005.

Sorry, we can’t reproduce on our side. The reason for this issue is Insufficient permission.
Please try again with an Administrator user account or Run cmd with administrator rights and check again.

Kind Regards,

I would uninstall and install the newest version from here and check again. After uninstalling I would also try running the official uninstaller as an extra precaution.