explorer.exe-OLE after last MS Update

Hi Guys,
{XP Pro, SP2; Comodo v2.4.18.184, DB v3.0; Comodo BOClean v4.25}
This request is not about “Comodo Firewall issue”, per say.
CPF works fine. (B) So if any Moderator finds that this Q should be moved to another place, please do. Thanks.

The following happened after applying latest MS Update (9 security tampons from 15/08/2007)
After that explorer-cvhost-OLE love triangle went bananas.
Comodo gives very frequent alerts, for example:
IP: http(80) - TCP
services .exe
C:\Windows\explorer.exe has tried… cvhost…through OLE…
I am ignoring (not responding to) all of them for now (which should result as “deny”)
The addresses are, e.g.:
…etc. I checked and those are “Asia Pacific Network Information Centre”.
When I ignore many of those, another group starts to annoy me, like:
…etc. I checked and those are “Microsoft Corp”.
Can anybody, please, give me some ideas:

  • why such behaviour (unseen before here) emerged after the last MS Update?
  • or is it just a coincident?
  • why is this sequence Asia Pacific Net… and then Small and Soft?
  • why those requests are frequent and so demanding?
  • would it bring some implications, if I just permanently Deny all of those?
    I know that I can experiment with the last one but I may not see all implications straight away.
    The last thing to add (despite it may not be relevant) – explorer.exe is blocked In/Out by me long time ago.
    Thanks in advance
    [Edited 19/08/07]
    I ran the latest security update for Win 2000 Pro box on my network
    (it was switched off for this couple of days).
    Peace and quiet. Nobody is trying to go out (at least for 12 hours already).

I “allowed” it, because it seems like I couldn’t connect online without it. Comodo also gave me alerts on Firefox, wich it never did before this week’s Windows Update. Firefox seems to run slow, even after allowing it.

Also, should I have explorer.exe blocked as well?.

Hi flange,
Connection and speed as well are fine here and no Qs about Firefox.
As I mentioned I am not responding to messages, which means Deny for Comodo as soon as the particular alert haven’t got any answer (that’s how I understand should be - “deny for this session”)