Explorer Crashes

This concerns the free firewall program, v. 6. I was using the earlier version for a long time but began to have problems with high CPU usage and decided to uninstall and re-install it. I then discovered that there was a new version of the program so I downloaded and installed that but when I rebooted explorer crashed as soon as the computer got to the desktop. I tried uninstalling it in safe mode and everything then worked normally. I tried uninstalling and re-installing it several times, including with the AV (GData) turned off but the result was the same every time. Does anyone know of a fix for this problem ? Thanks in advance for any input.

Hi and welcome dxmc4,
Before attempting to re-install I would consider running the unofficial Uninstaller Tool for Comodo Products in Windows Safe Mode.

Hi, and thanks for your reply, unfortunately it didn’t resolve the issue. The problem appears to be that v. 6 puts up a very large pop-up on the desktop as soon as the computer gets to the desktop and before explorer or any other programs can load. When explorer tries to put up the taskbar it crashes and that aborts the boot-up. This wasn’t a problem with the previous version but this new version appears to be extremely different.

I used the old program for a long time and I wanted to give this new version a fair chance but it doesn’t look like it’s going to work for me. The pop-up is annoying and obtrusive and I also don’t like having to customize the installer because it tries to install so much stuff. I just wanted the firewall but I suspect that the program’s efforts to do so much more may be a part of the problem with running it.

Can you please post a screenshot of this popup?

No, when I restart at the moment the desktop appears, after the user profile service has started, the pop-up is there with along with the explorer has crashed message. The desktop wallpaper doesn’t load, there’s just a blank screen with those 2 things. If I try ctrl-alt-del and start Task Manager that crashes. Explorer won’t restart, if I manage to close it, the start-up won’t continue, the screen just stays blank.No other program can be run because without explorer there is no taskbar.

The pop-up is a sort of welcome to the program thing advertising “Firewall” on one side and “Geek Buddy” on the other side, even though I didn’t install Geek Buddy. It fills about half the screen. I tried setting the program not to run at start-up but that time it put up a large pop-up right at start-up saying that it’s services weren’t running, accompanied by the usual crash.

When I look in Event Viewer it appears that there were major problems with the uninstall of the old version. Just after that happens a whole long string of error messages appear which mainly fall into 2 groups, Event ID 10010 errors indicating that numerous programs can’t be re-started, app sid doesn’t match conductor sid, and Event ID 513 CAP12 errors, indicating that;

Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object.

AddWin32ServiceFiles: Unable to back up image of service COMODO Internet Security Helper Service since QueryServiceConfig API failed

System Error:
The system cannot find the file specified.

There are also numerous DHCP errors. After this there is also an error message at every startup indicating a problem loading a driver associated with an unused card slot. So given that uninstalling the old program caused so many problems I’m not surprised that installing the new version immediately afterwards caused problems.

I have a recent system image backup and I am considering restoring it so I can uninstall the old program again if I can find a way to do it that isn’t going to mess everything up. But I’m naturally very reluctant to do that unless it’s absolutely necessary. With both versions now uninstalled things seem to be working and I am not really inclined to keep tampering with things. But if problems continue I may have no choice.

Try using the Geekbuddy removal tool to remove v6 completely.

Then uninstall G Data AV and run their removal tool. A list of removal tools can be found here: ESET Knowledgebase .

Now you will have a clean starting point. I suggest to start with Comodo Firewall and see how it goes. Then install G Data AV and see what happens.