Explicitly Trusting a network

Ok, I managed to get this working on v2.x but 3 is winding me up now!

I want to trust my home network 192.168.x.x to do everything, on all ports, all protocols.

There are several computers in my house (IPs in the network and network)
I want all of them to go straight through CFP no questions asked, all to be trusted for incoming/outgoing/round-in-circles, everything.

I managed to define a trusted network in v2, but v3 seems to only let you define zones, but not trust them.

I’ve played about with rules, allowing TCP/UDP In/Out requested from my home zone range… I managed to browse the shared folders on my PC from another by disabling the firewall, and trying… then I re-enabled firewall and it still works (though, I’ll put money on the fact that I’ll have to do that on every PC).

Any ideas please? Particularly I want to enable Windows Shared folder browsing and Remote desktop, but there are others aswell (so I don’t want to allow just ports).

I’ve so far been impressed with v2 and v3, but I’m feeling that it is rediculously tedious to set up (and I’ve got a Network+ and MCP in XP - still not afraid to ask for help though).

p.s info: CFP v3, xpsp2.

Many Thanks


Did you go to Firewall/Common Tasks/Stealth Port Wizard/Define a new trusted network? I don’t run my computers as a LAN, but this looks like it should work.

Ok, I have now…

FYI: I uninstalled, and reinstalled since my post. I selected the option to trust my network during the installation.

I have tried the Stealth Ports option you mentioned (Thank you BTW, but what the hell is it doing in there?), and I can still browse the shared folders as before (not sure if this was ‘remembered’ after uninstall or not), but Remote Desktop still does not work.


My log keeps showing:
C:\Windows\system32\svchost.exe Blocked (TCP, source port varies, but seems to be 1514-1517, destination port 3389). Destination and host IP addresses reflect my RDP attempt as does the 3389. My God I wish it would tell me which rule is kicking it!

Does it not understand that this network is TRUSTED!??!!?!

It must be paranoid.

Just so you know, CFP is in Training with safe mode, and I’ve tried the others too, but no joy (until I disable it).

Any more suggestions?? I really thought you’d nailed it with the last post.



Never Mind!

Found that svchost.exe was listening on TCP3389, which made me shout at the screen “You know it’s listening! So why won’t you let it through!?!?!” (insert some obscenities in there).

Also noticed the Application Rules for svchost.exe says it’s treated as “Outgoing only”… Genius!

Changed to custom, added an allow rule for TCP/UDP in my Network Zone, and viola, look at that, I’ve now remote desktop’d to the pc next to me, and from that - remote desktop’d back to this one, and successfully confused the hell out of XP… but at least it works now.

Thanks for your efforts.

Before I go… Any idea why CFP3 doesn’t list in LaunchPad?