Exclusions not excluding...

New user to CIS, so I’m still coming to terms with the program.

In my very first AV scan, (the one the software wants to do when you install it) I realized that I was going to have to exclude some folders as the AV engine takes an incredibly long time to scan. Every other AV program I have at my disposal (Several other on-demand scanners, only CIS is actively handling AV duties) takes less than an hour to scan my system, but CIS takes a whopping 4 1/2 hours!! I have a fairly fast current system, so this is just crazy. (Win XP, Media Center Edition SP2 (32bit) AMD64 X2 dual core 4200+ W/2GB RAM)

I noticed in particular that it was very slow reading my music files, and various game files.

Anyway, reading the help file about the exclusion list, it says that anything on the exclusion list will be excluded from all future scans of all types. So, I added my music folder and a few other problem folders to my exclusion list, and decided to wait until my weekly scan to see how much time I saved on the scan. (Currently, 4 1/2 hours just doesn’t cut it…)

So my scan started today, and I noticed that it started scanning what I had on my exclusion list! So then I thought, maybe the help file was worded incorrectly, and it meant that the list would be in effect in any future created scans. So I created a custom scan profile and started a new scan. Sure enough, the exclusions again weren’t excluded…

So what do I have to do to get CIS to exclude my exclusions? Is perhaps my syntax incorrect for excluding a folder?
C:\Documents and Settings\MyUserName\My Documents\My Music*
This is what CIS added as the syntax when I added the folder to the list, so I would hope it is correct, but you never know. I have tried “My Music*” As I saw in the default Comodo exclusion, (C:\Program Files\COMODO\COMODO Internet Security*) but that has no effect.

Any ideas? Because at the moment this seems broken.

Adding files to the exclusion list will still scan the files, but ignore anything found in them.
Why was is designed like this? I have no idea.

Wow, so it’s operating as intended?? That’s mind boggling!

I can’t even imagine why this would be considered a desired design “feature” by the programmers. I guess it would be easy to program this behavior because you wouldn’t really need to change anything but the alert, but from a usage (not to mention system resource) standpoint it’s just silly… Have Comodo come out and said this is what they intended, or is this function merely broken at the moment?

If it’s intended, the help file should probably be changed to reflect this oddity. It’s a bit misleading.
All items listed and all items added to the ‘Exclusions’ list will be excluded from all future scans of all types.
I can’t imagine anyone reading this and assuming that what it actually means is that the files will still be scanned, the only “exclusion” being the alert to the user of any detection found during the scan.

I hope this function(?) is changed in future updates, because honestly it makes no sense to scan “excluded” files.

Thanks for your help .FaZio93.!

I guess you can start a new wish. I don’t think there have been any threads on this yet. :wink:


Or you can add a new scan profile without those folders

True, but it’s definitely easier to only add a couple folders to an exclusion list and have those folders actually excluded.

Yes it is, but it’s not working. So a temporary solution is to create a new scan profile.

No, the temporary solution is to scan with another AV until Comodos scanning either doesn’t take four times as long as anything else, or is able to exclude certain folders. :wink:

I’m using Comodo as my real-time AV, but using Avira and Avast for on-demand scans.