Excluding folders from backup

I am running a backup with the following settings, using Comodo BackUp

Source folder → “D:”
Include subfolders → “Yes”
Relative folder →
Exclude folders → “D:\Download\Completed” and “D:\Download\News”
Backup type → “Full backup”
Compression → None
Destination → A folder on a 500 gigabyte external harddrive

I am trying to backup my D: drive, under Windows Vista Home Premium, as an administrator. I am trying to save some space by excluding to huge folders, which are not critical. However, both folders are included in the backup…

Ideas, anyone?

I’m very new to this, and don’t really know if your problem has anything to do with the one I mentioned here:
but in my case, although I thought the folder in question was showing to be excluded, when I went back to check, it wasn’t. Going through the process of selecting it to be excluded again solved the problem.

Hi HeavyB

andrewgg has given a solution that makes a lot of sense. Check it out first. Then there is still a couple of things you could try if that does not help you.
Try using the “Advanced exclude options” to the right of exclude mask.
The other one takes a lot longer to do and that is rather than exclude a folder enter one folder at a time as the source folder. This way you will enter all but the ones you choose not to. ( This will not be practical if your D:\ folder is very large.)