Exclude folders? [Solved]

Hello!

I’m currently playing around with Eclipse and CDT.
Every new selfcoded program I execute is being interfered by D+.
How can I tell D+ that all files in my workspace folder are safe?

“My Own Safe Files” lets me only add files and no folders.

Thank you & kind regards

Evening “Philee”

My name is Jacob Kilgore,
I’m one of the Moderators here at Comodo Forums
I would like to try to solve your Issue as Quick as Possible

I believe that you are looking on how to add a folder to be safe (Everything in the folder to be automatically safe?)
You can create a group then add it to the “Computer Security Policy”
Here is how you do that:
Open CIS > Defense+ > Protected Files > Groups > Add > New Group > (Name is workspace or somethign rather)
Then Apply > Highlight your New Group > Add > Select From > Browse… > Select the Folder/Drive > Click Arrow pointing right then Click Apply > Apply > Apply

You have created a New Group, Time to add it to the “Computer Security Policy”
Click Advance > Computer Security Policy > Add > Select > File Groups > Click “Workspace” or what ever you named it
then Click “Use a Predefined Polic” > Trusted Application > Apply > Apply

You have added your Created File/Folder Group To The Computer Securit Policy,
You Should not recieve any alerts at all

Did this help ?

  • Jacob Kilgore
    C-O-M-O-D-O Forum Moderator

Good morning Jacob ;D

Thanks for your help and the detailed instructions!

I’m not sure if I did something wrong but I still receive the alerts.
I attached some screenshots of the settings and also one of an alert.
Maybe you can tell me what I’ve done wrong.

Thank you and kind regards!

[attachment deleted by admin]

Hello,

(it’s 12:37AM Here)

Yes, You are recieving this alert because “starter.exe” is not in the group so it will be triggering an alert
To solve this either add “starter.exe” to the group or just answer this alert and select “Treat this application as: Trusted Application”

Did this help?

Hello!

(It’s 09:00AM here)

That’s really strange.
The entry in the “Computer Security Policy” for starter.exe constantly changes back from “Trusted Application” to “Custom policy”.
The D+ alert keeps popping up and there’s no option for treating it as a “Trusted Application”.

Thanks again and regards

[attachment deleted by admin]

Hello Again Philee

Try to do the following
Open CIS > Defense+ > Advance > Computer Security Policy > “starter.exe” > Edit > “Use a Custom Policy”
And Click Access Rights > Go Down the list and make all the bubbles fill in the “Allow” Bubble
This should die down the alerts but not all of them, you should only get a lert if this application is starting another

other than that it should be quiet, if you wish you could set it as “Installer or Updater” This will
quit the alerts, but it’s not recommended.

The reason it is changing, because even “trusted applications” when trying to execute another program a alert will pop up
So when the user answers yes or no, it will switch to “Custom Policy” because it has a added value/rule

Does this makes sense?

Does this help you?

  • Jacob Kilgore
    C-O-M-O-D-O Forum Moderator

Hello!

I found a solution!
In the starter.exe “Access Rights” > Run an executable > Modify you’re able to add a folder mask.
I think that’s the best solution.

≫ you should only get alert if this application is starting another
But we created a group for “Trusted Applications” and set starter.exe also as a trusted one. So there shouldn’t be no danger if a trusted application executes another trusted one.

≫ you could set it as “Installer or Updater” This will quit the alerts, but it’s not recommended.
This solution is also working for me but may I ask why it’s not recommended?

Thanks again for you help!

Edit:
Another thing I noticed.
The purge button doesn’t consider the entries under “Access Rights”.
The entries there still persist also after deleting them from the HD and then pressing the purge button.

[attachment deleted by admin]

Hello,

You are correct about the “Access Rights”, Maybe adding this to the Wishlist?

It’s not recommended because, if “unlikely” a hacker/malware gets inside your pc and modifies that file, that file is under “Installer or Updater” which that automatically has access to system files… that is why it’s not recommended :slight_smile:

Is your issue solved?

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

Okay, thank you!

Everything’s clear now. :BNC

-Topic Closed-

Possible Actions:

  1. PM a Moderator or Me to Unlock This Topic

  2. If You Have a Different Issue Please Search For The Problem, If You Cannot Find It Create a New Topic in The Correct Board/Category

  3. If You Have a Similar Issue Please PM a Moderator/User That Found The Solution To This Topic, He/She May Know How To Solve Your Issue Too

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

P.S.: You are Most Welcome Philee
If you have future Problems Please
Come Back To Comodo Forums And
Start A Topic About it